WordPress.org

Ready to get started?Download WordPress

Forums

Booking Calendar
[resolved] Select booking date doesnt work (11 posts)

  1. 96320
    Member
    Posted 2 years ago #

    Hi,
    When I'm trying to make a booking by clicking on a date in the calendar (which then gets highlighted), filling out me details in the form etc I get this message when I hit send button:
    "Please, select booking date(s) at Calendar"

    http://wordpress.org/extend/plugins/booking/

  2. wpdevelop
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,
    probabaly you are deactivated the loading of the "Bootstrap" scripts" at the client side of site at the General Booking Settings page. The Bootstrap files are required for the working of the plugin, and you can deactivate it only if the theme or some other plugins is already loaded it.

    If you are activated those scripts, and have no visible calendar atthe site, so most common reason of not loading actual version of the jQuery. The booking Calendar version 4.0 is require at least version 1.7.1 or newer of the jQuery.
    The WordPress installation 3.3.2 have this jQuery package inside of own installation, so if you are use the older wordpress installation, please update it.

    Please check the troubleshooting instruction here: http://wpbookingcalendar.com/faq/calendar-not-visible/

    More detail about this issue:

    Error: a("body").on is not a function
        Source: .../booking/interface/bs/js/bs.min.js
        Line: 7

    Solution:
    Its seems, that this issue is because your theme is used the old version of jQuery.
    Please, download the latest version of jQuery and integrate it into your actual theme or just use the latest version of jQuery from WordPress installation (just comment loading of the jQuery from the theme and the Booking calendar will add load of the jQuery from your wordpress installation (of course, recheck that this installation also have to be up to date))

  3. 96320
    Member
    Posted 2 years ago #

    Thank you very much for your quick reply.

    I dissabled Bootsrap loading and that fixed that issue.

    Now i face a new problem, when I click "send" a popup window with "404 error" is displayed.

    I have checked the permissions on my server and they are all set to 775. The .htaccess file contains just the sandard wordpress text.

    When I change to "redirect visitor to a new thank you page" I still get the pop-up window, even though I have created and published (and viewed) the thank you page".

  4. wpdevelop
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,
    Please update the plugin to the version 4.0.1.
    If you are use the free version, you can update it from the WordPress directory.

    P.S. You have not to disable the "bootstrap". These files are required by plugin. In the previous comment, I am not mentioned about the disabling these scripts.

  5. 96320
    Member
    Posted 2 years ago #

    Oh no.. I just updated to the latest version, but now the first problem is back again! I have tried both with dissabling/enabling the bootstrap. I updated the other day to the latest wp so my jQuery is the latest (I also checked this on the server). I know there's a lot of java script and jQuery in my theme so I temporarily activated the default theme (twentyten) but it still doesnt work to select dates..

  6. wpdevelop
    Member
    Plugin Author

    Posted 2 years ago #

    Please send the link to the page with the booking form, for retesting it.
    Thank you.

  7. 96320
    Member
    Posted 2 years ago #

    Hm.... I reloaded the page a couple of times and now I can select again but the 404 msg is back! http://www.daniellescottcosmetictattoo.com.au/login/

  8. wpdevelop
    Member
    Plugin Author

    Posted 2 years ago #

    Its was because previously your browser are used the old scripts. You was need to clear the browser cache before that.

    According the 404 error.
    Its seems that inside of the .httaccess file or by using some plugins..etc, you are disable access to this file:
    http://www.daniellescottcosmetictattoo.com.au/wp-content/plugins/booking/wpdev-booking.php

    The booking calendar is send the requests using the ajax technology, and its need that this file was accessible. Please recheck at your server configuration.

  9. 96320
    Member
    Posted 2 years ago #

    Still doesnt work..
    I have now deactivated all plugins but booking calander
    I've set permissions to 775 on the server on the plugin,
    I have set to redirect the page to the start page instaed of displaying the "thank you" message (i.e this http://www.daniellescottcosmetictattoo.com.au/wp-content/plugins/booking/wpdev-booking.php)

    My .htacess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Is there anything I can add in the htaccess for it to work?

  10. wpdevelop
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,
    please recheck the permissions to the folders wp-content, plugins and booking. May be one of this folder have fully deny access (please note, you are need to have only access for the php script execution, not full access).

  11. 96320
    Member
    Posted 2 years ago #

    Ahaa I always though I needed to change to 755 but turns out the server didn't allow this, so when I changed to 444 (wpdev-booking.php and also in the wp-admin folder), it works!

    Manyy thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.