WordPress.org

Ready to get started?Download WordPress

Forums

Security Plugin Blocks Login Page (10 posts)

  1. sdlynn
    Member
    Posted 2 years ago #

    I don't know if anyone can help me with this, but I'm pretty new at this. My site was working fine until I installed a security plugin and went with the recommendations it gave to beef up security on the site. Now that I've logged out, I can't access the log in page to my site. It automatically goes to "page not found." Any suggestions?

  2. jennifer2010
    Member
    Posted 2 years ago #

    Try accessing a page within your admin panel. (ie yourdomain.com/wp-admin/theme-editor.php ) and see if it automatically directs you to the correct login page.

    If not, connect to your site via FTP and go to:"
    public_html > wp-content > plugins

    and rename the security plugin folder from whateveritsnameis to 1whateveritsnameis so you can log into your site again. Then rename back and see if what it's doing to the login page.

  3. carams
    Member
    Posted 2 years ago #

    I'm having a similar problem, though I don't know what is the root of the problem.

    Until a couple of days ago, I was accessing my admin & login pages direct from the browser. Then I cleared cookies etc and since I did that, I am unable to access the login pages.

    http://www.carams.fr/wp-admin

    http://www.carams.fr/wp-login.php

    I've tried accessing the FTP via FileZilla and it is rejecting my login and get the message '530 login incorrect'.

    Any pointers.

  4. sdlynn
    Member
    Posted 2 years ago #

    I tried both of those things, still nothing. I even tried to delete the security plugin from the FTP site and still no results. I get "page not found." should I just reload the website and start over or is there something else I can do?

  5. justingreerbbi
    Member
    Posted 2 years ago #

    Setting have been changed in the database. You can use you wp-config.php or themes function file to change setting back to normal..

    update_option('siteurl','http://example.com/blog');
    update_option('home','http://example.com/blog');

    or

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Refer to here for more info

    http://codex.wordpress.org/Changing_The_Site_URL

    It looks as if the plugin changed the login url

    have you tried logging into your site using http://www.example.com/wp-login.php?

  6. justingreerbbi
    Member
    Posted 2 years ago #

    @carams

    Ftp Does not just go down... do you have acces to your admin panel for hosting? Cpanel or godaddy ect.. You can reset and check your FTP account there.

    Alo from time to time hosting providers reset default passwords and such fo security so just duble check with you hosting support team

  7. sdlynn
    Member
    Posted 2 years ago #

    I'm pretty new to this, so I'm at a loss.

  8. carams
    Member
    Posted 2 years ago #

    @justingreerbbi

    I've accessed my host and created a new FTP access so I can now access that.

    I still don't can't open either

    http://www.carams.fr/wp-admin

    http://www.carams.fr/wp-login.php

    Am I going to to need to follow the steps to the link you posted above?
    http://codex.wordpress.org/Changing_The_Site_URL

    Thx.

  9. Help2day
    Member
    Posted 2 years ago #

    After trying to update Constant Contact plugins I got this
    Warning: require_once(/home/content/n/u/t/nutkings/html/wp-content/plugins/constant-contact-api/admin/contacts.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/n/u/t/nutkings/html/wp-content/plugins/constant-contact-api/constant-contact-api.php on line 41

    Fatal error: require_once() [function.require]: Failed opening required '/home/content/n/u/t/nutkings/html/wp-content/plugins/constant-contact-api/admin/contacts.php' (include_path='/home/content/n/u/t/nutkings/html/wp-content/plugins/google/lib/external/google:.:/usr/local/php5/lib/php') in /home/content/n/u/t/nutkings/html/wp-content/plugins/constant-contact-api/constant-contact-api.php on line 41

    Now I can't get in-what should I do

  10. sdlynn
    Member
    Posted 2 years ago #

    I contacted help and support with my host and they said the htaccess files had been altered. He changed them to oldhtaccess and now I'm able to log in.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags