WordPress.org

Ready to get started?Download WordPress

Forums

Easy Sign Up
[resolved] Security error (20 posts)

  1. mamabird31
    Member
    Posted 1 year ago #

    I just added this widget to my website with no modifications. I tried it both with the short code and with the widget. When I submit the form I get a blank page with only these words: "Failed Security check - are you a robot?" I can't find anything on this anywhere. The url parameter for that error page is ?esu_qv=true if that helps.

    Thanks!

    http://wordpress.org/extend/plugins/easy-sign-up/

  2. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    The form has a system that checks for a nonce. The reason we have this is because some robots will just hammer a form if they know what the fields are. Having a nonce in place puts the hand break up on this bad behavior because the robot can't guess what the value of the nonces should be.
    For some reason this check is failing on your website.
    What is your WordPress version? What is the Operating system of your server?
    What is your URL?

  3. mamabird31
    Member
    Posted 1 year ago #

    WordPress 3.5.1
    The OS is Debian Linux
    The URL is http://www.sahfahoa.org/wordpress/hoa-events-2/

    Thanks!

  4. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks mamabird31, one final question to help trouble shoot this:

    Disable all your other plugins and switch to the default WordPress theme for a bit.

    If the problem persists let me know.
    if not, figure out which plugin is the cause of the problem let me know which plugin plugin.

  5. mamabird31
    Member
    Posted 1 year ago #

    I disabled them all, switched to 2012 and it still happens. You can see on the same URL as above.
    Thanks!

  6. helveticadesign
    Member
    Posted 1 year ago #

    I too am having this problem!

    WP 3.5.1
    OSX Mountain Lion
    URL http://dlindustrial.com.au/staging/about-us/ (Sidebar)

    Thanks!

  7. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Folks I think I have found I common denominator - both of your WP installations are not in the root DIR of your web space. It's super late here but I'll come up with a fix tomorrow. Thank you so much for your feedback as I would have probably never found this bug.

  8. helveticadesign
    Member
    Posted 1 year ago #

    No problems! Not a massive issue if it doesn't work on staging, just as long as it does when the site is launched. Thanks very much!

  9. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    Hi mamabird31 and helveticadesign,
    I just pushed up an update that should sort out your issues with the plugin robot check.

    The issue was unrelated to your staging servers.
    I believe it was cause by the forms submit URL not having a forward slash (/) between the end of the website's URL and the query string '?esu_qv=true'.

    I am not a server wizz but for some reason this was preventing your servers from posting the from's data.

  10. mamabird31
    Member
    Posted 1 year ago #

    Thanks for the fast response time! I updated the plugin,changed back to my other theme and tried it again. It redirects me like it should, except I am not receiving either the redirection email or the client email. Could this be from the update or have I not configured something properly?

    Thanks!

  11. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    mamabird31 try the following:

    1. Check your spam folders
    2. Change the email addresses in the easy sign up setting panel and see if this has any effect
    3. Check that your server allows emails to be sent out
      • If for some reason it does not, you can by pass it with a service like https://mandrillapp.com
      • They have a plugin - it takes over the wp_mail() function and by passes your server.
      • It's a bit of a pain to setup as it requires an account and an API key.
      • Free emails are limited to 25 per hour
      • Easy Sign Up generates 2 emails each time the form is filled out so that's 12 sign ups per hour
  12. helveticadesign
    Member
    Posted 1 year ago #

    Working perfectly now! Thanks very much for your speedy help. You're the best!

  13. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    No worries - helveticadesign - please take the time to give us a quick review @ http://wordpress.org/support/view/plugin-reviews/easy-sign-up

    Thanks :)

  14. mamabird31
    Member
    Posted 1 year ago #

    Thanks for all your help Greenweb! Turns out our host doesn't allow the sending of spoof emails but they directed me to a WP plugin that was very easy to install - after 10 minutes I'm up and running. I appreciate your quick response time!

  15. Greenweb
    Member
    Plugin Author

    Posted 1 year ago #

    That's to bad. The plugin doesn't do anything funny when it comes to sending out the email as it uses WP own mail function. I assume that they must block WP password recovery if that is their standard.

    Thanks for the update, please share the name of the plug in your using just in case someone else runs into this too.

    Cheers :)

  16. mamabird31
    Member
    Posted 1 year ago #

    Sure. It's Contact Form 7. Not sure what's different but when I installed it and input my info it sent the emails right away. Anyhow, I appreciate you doing all you can to help with your plugin!

  17. mattrussell
    Member
    Posted 11 months ago #

    Hey there,

    I'm having the same issue, but I would really like to resolve it rather than install another plugin, as I have already styled the element. I also can't deactivate my other plugins as I'm using an e-commerce them and its a bit temperamental.

    Is there a way to bypass the security check?

    Thanks

    Matt

  18. Greenweb
    Member
    Plugin Author

    Posted 11 months ago #

    Sorry that there is an issue - I can't help you resolve it if I don't have all the info.

    When you say:

    as I have already styled the element

    Did you mean that you styled it via CSS or are you hard coding in the form?
    If your are hard coding the form, as a-posed to using the shortcode or widget then the issue is that your site is not creating the nonce.
    If you want me to look at your site please post in the URL.

    Having said that if you want to disable the nonce security check, you can go into the following file: /lib/esu-form-process-class.php
    On line 140 find the function named esu_check_nonce() and change it to this:

    function esu_check_nonce(){
        return self::esu_post_vars();
    }

    Warning: This change will be over written if you ever update the easy sign up plugin.

    This would be the better way to troubleshoot: http://wordpress.org/support/topic/please-read-and-follow-the-following-guidelines-before-opening-a-new-topic?replies=2

  19. mattrussell
    Member
    Posted 11 months ago #

    Hey,

    thanks for the quick reply. much appreciated.

    Ya im only using CSS to style I haven't touched the plugin code. I just mentioned that as another member suggested to use another plugin, so that's why I didn't want to do that.

    Here is the link: http://lens-media.com/newshop/home/

    If you scroll down you'll see a mid section with an email text-input field; that is referencing from the plugin short-code.

    I am only using the email input could that be an issue why the security check is failing?

    thanks again

  20. Greenweb
    Member
    Plugin Author

    Posted 11 months ago #

    Matt that possibly is the problem. How are you removing the name field?

    i have to leave the office but I get back to you tomorrow morning

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic