WordPress.org

Ready to get started?Download WordPress

Forums

Visual Form Builder
[resolved] Security check: referal does not match this site. (46 posts)

  1. timjin
    Member
    Posted 1 year ago #

    I get this error when I submitting forms, I have updated every version that has come out and have had no issues until this recent update. Any idea what the error could mean?

    http://wordpress.org/extend/plugins/visual-form-builder/

  2. steefer
    Member
    Posted 1 year ago #

    I've got the same problem after the new update.

    Before this error I also have the problem that the form says that it was sent succesfully but the email never arrives. I tried the Advanced Email Options plugin but without succes. Anny suggestions would be great!!

    i'm using the pro version.

  3. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    This is a new security measure introduced to prevent your form from being used by spammers to submit the form from another URL.

    Post a link to your form as well as any information about your hosting/server that might be useful. Thanks!

  4. steefer
    Member
    Posted 1 year ago #

    Hello Matthew,

    Here is the link to my form
    The site located on a (slow) server VPS server. (www.yourhosting.nl

    Thanx

  5. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Looks like your permalink settings are not being picked up by the code to get the current URL. I'll have to find a fix that is suitable for both permalink types.

  6. oscarturtle
    Member
    Posted 1 year ago #

    Hi there, I get the same error. The form is on http://ahes.org.au/?page_id=503 and is hosted by Hostpapa (http://www.hostpapa.com.au).

    Thanks a lot!

  7. tgd
    Member
    Posted 1 year ago #

    I get the same issue since the update. I'm using this on a number of sites. Perhaps a downgrade until this issue is fixed?

  8. tgd
    Member
    Posted 1 year ago #

    I have updated to your latest version 2.7.3 showing bug fix for some permalink structures, but it still doesn't work.
    my main site is http://www.royaltylimousine.ca/

  9. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Changing this back to Not Resolved since the fix is not playing nicely with domains that use "www".

  10. steefer
    Member
    Posted 1 year ago #

    The update works for me thanx!!!
    Now i have still the problem that the email that was sent not arrives :-(

    Any tips?

  11. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    If anyone wants to help test a patch, let me know!

  12. tgd
    Member
    Posted 1 year ago #

    I'd love to, but it turns out the only site I applied the update to, so far is that Limousine service. I'll hold off on any further updates, as most sites use 'www' in the URLs. Curious though. You say it's for security to keep out spam, but each form has a pseudo captcha type of feature that cannot be removed (fill in two digits..). Because of this, I have yet to get a single piece of robot generated spam from any form I've used.

  13. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    I'm not sure I get your reasoning for not wanting to test, but okay. I've already tested the patch on my site, which doesn't append the URL and it works. That leaves your site and others like it that prepend www. It'd be a big help if someone could test this before I push out an update to thousands of people.

  14. tgd
    Member
    Posted 1 year ago #

    I'm just hesitant testing it on a client site, right now. Its active and there is traffic to the site that Id prefer not to risk disrupting.

  15. tgd
    Member
    Posted 1 year ago #

    I can test it elsewhere, I suppose though...

  16. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    If the form already isn't working because the domain uses www, then me applying this patch can only help things, yes?

    If you are still interested, send me an admin login and I'll take care of it. Thanks!
    http://vfb.matthewmuro.com/contact

  17. oscarturtle
    Member
    Posted 1 year ago #

    Hi Matt,

    I'm happy to test for you but I'm at work now so it wont be for another 8 hours or so.

    Cheers

  18. tgd
    Member
    Posted 1 year ago #

    Hi Matt,
    I sent you the admin login...
    Thanks.

  19. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Terry was kind enough to let me test on his site and it looks like it'll work just fine. I'll get an update out tomorrow for this.

  20. o.selaff@boa42.de
    Member
    Posted 1 year ago #

    I use the Pro-Version 2.3.1 and still have this problem!

  21. alexjgraves
    Member
    Posted 1 year ago #

    Hi,
    I am getting the same 'Security check: referal does not match this site'
    message when a form is submitted. Here is a link to the form:

    http://www.cornwalltoday.co.uk/awards/nominate/

    Any help/advice would be much appreciated

  22. o.selaff@boa42.de
    Member
    Posted 1 year ago #

    I got a late note from my wordpress-System that 2.3.2 is already released. After installing it - all works very fine again!

  23. tgd
    Member
    Posted 1 year ago #

    Matt, sorry for the later response. Your fix is perfect. Works on all my sites prepended with www.

  24. jhetrick62
    Member
    Posted 1 year ago #

    Matt, I'm running 2.7.1 Visual Form Builder Pro. Has the patch for that been released yet as It's not showing up in my WP install and I had a customer complaint about this very error today?

    Thank you.

  25. alexjgraves
    Member
    Posted 1 year ago #

    Hi,
    Anyone had any luck with this yet? Still not working and need to get my form live. May have to use another plugin.

  26. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Folks, this has been resolved with the latest version of the free and the Pro. If you are using the free, you need version 2.7.4. If you are Pro, then you need version 2.3.2. Both of these versions have been available for over a week.

  27. alexjgraves
    Member
    Posted 1 year ago #

    Hi Matt,

    I am running 2.7.4 of the free version but still no luck. Do you think I need to re-install?

  28. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Post a link to your form that is not password protected as well as any server information you can provide.

  29. alexjgraves
    Member
    Posted 1 year ago #

    Hi Matt,

    Thanks for the reply, here is the link with password removed:

    http://www.cornwalltoday.co.uk/awards/nominate/

    What is the kind of server information you need?

    Cheers
    Alex

  30. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    I just tested the form and it works just fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.