WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Security and WP 1.5.2 (7 posts)

  1. jfriesen
    Member
    Posted 8 years ago #

    Hello--

    I just came across this:
    http://www.securityfocus.com/bid/17069/info

    The article mentions that all versions of WP prior to 2.0.2 (going back to 0.7) are vulnerable to input validation.

    I've been hesitant to upgrade to WP2. There seemed to be alot of problems when it was first released, and many plugins were not compatible. Perhaps things are better now? I have MANY WP 1.5.2 sites so I need to know that upgrading isn't going to break the sites.

    Is there a manual way to patch this vulnerability in 1.5.2?

    TIA!
    JF ;)

  2. Kafkaesqui

    Posted 8 years ago #

    http://www.liewcf.com/blog/archives/2006/03/wordpress-153-beta-1/

    Not an "official" release, but it's an option.

  3. Mark (podz)
    Support Maven
    Posted 8 years ago #

    If you want just the changed files from 1.5.2
    http://www.tamba2.org.uk/downloads/wp-1.5.3-changed-files.zip

  4. klklaser
    Member
    Posted 8 years ago #

    Podz, after uploading your zip file files, is it necessary to run upgrade.php?

  5. Kafkaesqui

    Posted 8 years ago #

    Even when it's not necessary running upgrade.php hurts nothing.

  6. Mark (podz)
    Support Maven
    Posted 8 years ago #

    klkaser - no it is not but like Kaf says it'll not hurt.

    The files also came from a dev so there are no worries about me and my lack of coding abilities :) I'm just making them available.

  7. jfriesen
    Member
    Posted 8 years ago #

    Thank you so much!! Very helpful replies and exactly the answer I was looking for. Thank you!!!
    JF ;)

Topic Closed

This topic has been closed to new replies.

About this Topic