WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Secure WordPress] Conflicts with Long HTTP Requests (3 posts)

  1. Joel
    Member
    Posted 4 years ago #

    As of Secure WordPress v0.8 (03/04/2010), certain API's requiring lengthy http requests will fail.

    This affects all plugins and custom code using an http request with a string length greater than 255 characters (possibly affecting Google Maps and Twitter API functionality). It's more of a feature than a bug, but this "feature" severely limits functionality that may be required by certain websites.

    Fortunately, the changelog (please use this with your plugin if you don't already) noted the specific code implemented in v0.8 of Secure WordPress. Otherwise, it would have potentially taken much longer to debug.

    I'm checking now, but it appears that on line 606 of the secure-wordpress.php plugin file, the manage_options capability is spelled wrong. Will drop a note here if that fixes it.

    Sadly, I must deactivate until this limitation is changed or removed.

  2. Joel
    Member
    Posted 4 years ago #

    There is a typo in Secure WordPress, but apparently the error I was receiving was fixed via my code, but I imagine this may affect someone anyway.

    Either way, marking as resolved. Sorry for the false alarms.

  3. Frank
    Member
    Posted 4 years ago #

    Thanks - i had fixed this on 0.8.2.

Topic Closed

This topic has been closed to new replies.

About this Topic