WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Secure HTACCESS File : 500 internal server error (11 posts)

  1. Webullition
    Member
    Posted 1 year ago #

    Hello,

    I installed Bulletproof security .47.9 on my self-hosted WordPress 3.4.2.

    I wanted to activate the Bulletproof security mode, so I cliked on the AutoMagic button to generate the secure htaccess file. Then I activated the Bulletproof mode -> 500 internal server error.

    I tried on a localhost server (WAMP) with the same wordpress and it worked. I don't know what to do. I've read others topics here about 500 errors but it didn't help me. My site is not on a subdomain or a subdirectory.

    If you could help me, it would be nice. Thank you.
    Best regards

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Most likely your web host does not allow you to use the Options directive in htaccess files. Please see the forum link below for the solution. Also there are a couple of other things that can cause a 500 error, but look at this help section first - 500 Internal Server Error After Activating BulletProof Mode for your Root Folder

    http://forum.ait-pro.com/forums/topic/read-me-first-free/

  3. Webullition
    Member
    Posted 1 year ago #

    Thanks for your help.
    I commented out the "Options -Indexes" line but it does not work.
    Still the 500 internal server error.

    Do you know what else could cause such an error ?

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have cPanel?
    Which web host do you have?
    What is your Server type? Linux or Windows or something else?

  5. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Also some web hosts do not allow this htaccess directive.

    DirectoryIndex

    Try commenting that line of code out.

  6. Webullition
    Member
    Posted 1 year ago #

    It worked ! I commented out the DirectoryIndex line.
    Thank you ;)

  7. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Yep I keep meaning to add that on the Forum page. Will do it right now before i forget again. ;)

  8. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    I have added this to the Forum. Please resolve this Thread. Thanks.

  9. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Out of curiousity which Host do you have?

  10. Webullition
    Member
    Posted 1 year ago #

    My web host is NordNet (nordnet.com).
    And my configuration is :
    Server Type: Apache/2.0.54 (Unix)
    Operating System: Linux.

  11. Webullition
    Member
    Posted 1 year ago #

    Thank you for your help !

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic