WordPress.org

Ready to get started?Download WordPress

Forums

Second WP install's an SMF's directories point to 404 (8 posts)

  1. exiledesigns
    Member
    Posted 4 years ago #

    Hi!

    I've installed WP so many times, and I don't recall ever encountering such a problem.

    I've got my 2.8.6 installed at the root of the website (La GAMIQ) and then, I installed a second WP 2.8.6 in the /wiki/ directory... and finally, an SMF (Simple Machine) Forum in the /forum/ directory.

    Whenever I try to access the forum or the wiki I get either a 404, a 403 or a completely blank page (currently, it's the blank page).

    Here's how my root .htaccess looks:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    My /forum/ .htaccess doesn't contain anything.

    And my /wiki/ .htaccess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wiki/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./wiki/index.php [L]
    </IfModule>
    # END WordPress

    Any idea is welcome, thank you!

  2. Claude Vedovini
    Member
    Posted 4 years ago #

    try this in your /wiki/.htaccess file:


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

  3. exiledesigns
    Member
    Posted 4 years ago #

    Tried it, thank you, but still doesn't work!

    The forum (SMF) isn't WordPress based and hasn't anything in the .htaccess at all, also, and doesn't work either.

    My host (Acenet INC) allows to have several domain names pointing on directories. When I developped the website, I worked under:
    http://www.mainwebsite.com/gamiq/
    And when it had to go live, I updated that info to lagamiq.ca in both WordPress installs (admin side) and SMF admin.
    I'm now wondering if it had something to do with that - since they both seemed to work previously.

  4. Claude Vedovini
    Member
    Posted 4 years ago #

    You should remove the rewrite rules in the root and check that SMF and the wiki are working.
    For SMF, check the Settings.php file it must contain absolute path information to the forum folder that might have changed when you went live.

  5. exiledesigns
    Member
    Posted 4 years ago #

    If I remove the rewrite rules in the root, the wiki works! But not the forum... but it isn't blank anymore: it's an internal server error (403?).

    I've also checked the SMF settings but they're OK.

  6. Claude Vedovini
    Member
    Posted 4 years ago #

    I think you should define all your rewrite rules in the root .htaccess starting with those for /wiki/ and /forum/ otherwise it's not going to work.

    it should look like:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^wiki/. wiki/index.php [L]
    RewriteRule ^forum/. forum/index.php [L]
    RewriteRule . index.php [L]
    </IfModule>

    then leave the others empty.

  7. exiledesigns
    Member
    Posted 4 years ago #

    Thank you again, but... sigh :(

    The solution above removes all connexion between my root WP install & the theme (no more CSS). The wiki is OK, but then, the forum is still completely blank.

    I'm now checking with my host to see if it's a cache issue or something related to the subdomains.

  8. exiledesigns
    Member
    Posted 4 years ago #

    Okay, everything works now thanks to the quick and responsive techies over at Acenet (yay!).. but that didn't have anything to do with the .htaccess files.

    I hope this may help anyone with folders on subdomains acting strangely :)

    It was a 777 permission (writeable by group) on the /forum/ folder. Putting it back to 755 solved the Internal Error.

    Thank you very much for the help, Claude!

Topic Closed

This topic has been closed to new replies.

About this Topic