WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] second blog not linking to main site (12 posts)

  1. arika
    Member
    Posted 3 years ago #

    I installed a second blog onto my page and the install was successful. I have the super admin controls where I have added the second site. However, I cannot find it to type my posts or add the blog to my main page as a the second blog.

    The other issue I am having is when I go to super admin and then sites the the siteurl is written like http://example.comsecondblog/ (there is a / missing after the .com) I try to manually edit this but then it will not change after I hit save.

    I am using dreamhost if this makes any difference.

  2. Jason
    Member
    Posted 3 years ago #

    Use phpmyadmin to confirm the database > options table has the correct siteurl value.

  3. chriseggleston
    Member
    Posted 3 years ago #

    1st issue:
    To access you new blog and write a post you need to go to,
    Super Admin -> Sites -> Hoover over your new site name click on "Backend"

    That will get you to the new dashboard and it works like any WordPress site.

    (not sure if I understand your question completely?)

    2nd issue:
    To edit the site url you need to do this,
    From Super Admin -> Click on Sites -> hoover over the site you want to edit-> click edit -> edit the url in the first section (titled Site Info) of the edit page -> click update options for that section

    Then do this,
    Go to the second section titled "Site Options" (same edit page) change the "Siteurl" in the first box (if it is still incorrect) -> click update options for that section

    (Let me know if this helped at all, I am having some difficulty understanding your requests completely)

    -Chris

  4. arika
    Member
    Posted 3 years ago #

    Chris,
    I was able to edit the link (thank you) and I was able to find the dashboard (thank you again). However, when I click on the dashboard for my 2nd blog it says..

    Error 404 - Not Found

    Sorry, the page that you are looking for does not exist.
    Categories

    * Uncategorized (1)

    Archives

    * August 2010

    Links

    * Documentation
    * WordPress Blog
    * Suggest Ideas
    * Support Forum
    * Plugins
    * Themes
    * WordPress Planet

    Meta (and so on....)

    Any ideas on why the dashboard will not show like the other one and why it says page not found at the top? I feel like I am so close..

  5. chriseggleston
    Member
    Posted 3 years ago #

    What happens when you go to the website, not the dashboard? Does the site show up or do you see the same error message?

    So you have WordPress 3.0 installed, you activated Networks, you have one WordPress website installed at example.com and a new one and example.com/blog...Am I understanding this right?

    I would delete that site, sense you have not added content or anything yet...

    Super Admin -> Sites -> hoover over the site title -> click delete -> confirm

    Then start over...

    Supper Admin -> Sites -> Bottom of page Add Site -> Fill in the details -> Click Add Site

    If your new one messes up again then there is a problem somewhere else...probably with your Network setup.

    Here is one other thing you could check before deleting...

    Super Admin -> Sites -> hoover over the site you want to edit-> click edit -> Find the section "Site Options" -> Scroll through and make sure all the url's are properly displayed as they should be, so they are like the one you set in the section "Site Info"...

    -Chris

  6. arika
    Member
    Posted 3 years ago #

    I set up the second blog following these instructions http://catn.com/2010/08/09/enabling-wordpress-3-0-multi-site/

    When i did it all some of my formatting went away but here is my site http://www.arika.dreamhosters.com/

    my second blog is called recipe cards it comes up like this in the status bar (I am not sure why because I only entered recipecards)
    http://www.arika.dreamhosters.com/arika_dreamhosters_com_1recipecards/wp-admin/

  7. arika
    Member
    Posted 3 years ago #

    Chris,
    If i take out that arika_dreamhosters_com_1 and just leave recipecards I get to what looks like my site just with no content. Very strange. Where is the coding that adds that arika_dreamhosters_com1 stuff????

  8. chriseggleston
    Member
    Posted 3 years ago #

    I get lost here: arika_dreamhosters_com1 I am not sure what this is? Is your domain name arika.dreamhosters.com/?

    It looks like your main WordPress is installed in a sub-director and not the root (main) directory of your site...It seems like the problem has something to do with the way you your hosting is set up?

    -Chris

  9. arika
    Member
    Posted 3 years ago #

    yeah my domain is arika.dreamhosters.com that arika_dreamhosters_com automaticlly appeared on its own when I typed in my second blog site as recipe cards.

  10. arika
    Member
    Posted 3 years ago #

    My wordpress is installed under the root I think so it is root/arika.dreamhosters.com

    Then it said to find my wpconfig file and add the Wp allow multi site (which I did and the super admin turned on so I think that is right). It aslo said to add this..

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.arika.dreamhosters.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define('WP_POST_REVISIONS', false );


    , so I did that. Then I had to add stuff to my htaccess file.. here is the whole file..

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

    I think something in my wpconfig file might be wrong. Is it okay to post that file here. It doesnt say happy blogging at the end and all the things I read about adding a second blog said add that to the end of a file. So, maybe my wpconfig file is all wrong.

  11. arika
    Member
    Posted 3 years ago #

    Chris, I GOT IT!!!!!!

    I think it was having issues because I was working with a sub-domain so I created a real domain and re-did everything and it worked in less than 5 minutes. I had spent well over 10 hours on it and it worked in 5 minutes. Anyway, thanks for your help.

    arika

  12. chriseggleston
    Member
    Posted 3 years ago #

    Glad to hear it! Good job!

    -Chris

Topic Closed

This topic has been closed to new replies.

About this Topic