WordPress.org

Ready to get started?Download WordPress

Forums

Search results page pagination leading to 404 error (13 posts)

  1. meredith1986
    Member
    Posted 1 year ago #

    When I search for anything with more than one word (i.e. "the dog"), the search results page displays the first page fine, but if I try to go to page 2 or higher, I get a 404 error. I noticed that in the URL, it doesn't put the + in between the search words. However, if I add the + manually, I can view all pages of the search results fine.

    So, this gives me a 404 error: http://domain.com/search/thedog/page/2/
    But this displays the content fine: http://domain.com/search/the+dog/page/2/

    How do I get it to add the plus symbol (+) into the URL?

  2. keesiemeijer
    moderator
    Posted 1 year ago #

    Are you using a plugin for your search results pages. I think the normal url for a search is like this: http://domain.com/?s=the+dog&submit=Search

  3. meredith1986
    Member
    Posted 1 year ago #

    No, I'm not using a plugin. I am using a WooThemes theme though, so I'm not sure if that affects anything.

    The URL of the first page looks like this: http://domain.com/?s=the+dog&submit.x=0&submit.y=0&submit=Go

    But when I click page 2, it looks like this: http://domain.com/search/thedog/page/2/

  4. keesiemeijer
    moderator
    Posted 1 year ago #

    If it's not a plugin it must be the theme. Normally you would get urls similar to this on paginated search results: http://domain.com/page/2/?s=the+dog&submit=Search

    Something is rewriting the search pages url to /search/...

    Since this is a probably commercial theme with its own functionality and support system, I recommend you contact the theme developer for assistance.

  5. meredith1986
    Member
    Posted 1 year ago #

    Ok, well that sucks. Unfortunately I don't have a login to their support system.

    Any idea what template I should look in to edit the code?

  6. keesiemeijer
    moderator
    Posted 1 year ago #

    Just to be sure it's the theme that rewrites the url switch to the default (twentyeleven) theme and see if it still happens.

    Other than that, I would suggest you buy the theme so you can get support for it.

  7. meredith1986
    Member
    Posted 1 year ago #

    I did something which I think is similar to what you suggested. I replaced the Woo Search widget with another one called Advanced Search Widget. When I did the search, I had the exact same problem...pages 2 and up return a 404. Page 1 worked, but looked like this: http://domain.com/?s=the+dog&posttype=post&widget=advanced-search-widget-2.

    Could the issue be related to the pagination code?

  8. keesiemeijer
    moderator
    Posted 1 year ago #

    Could the issue be related to the pagination code?

    Yes it could, but we have no access to the theme files so we can't troubleshoot it. Do you have the same issue when you switch to the default theme?

  9. meredith1986
    Member
    Posted 1 year ago #

    I am so afraid to switch themes, then switch back. I have edited so many theme files. Will everything return to normal if I do this?

  10. meadows.pete
    Member
    Posted 1 year ago #

    I thought I would reply as I'm experiencing the same issue, my client reported it today. I'm using WooStore with WooCommerce.

    The ampersand is lost within the URL string for subsequent results pages which joins the two words together and thereby leads to a 404.

    I do however have access to their support and I've raised a ticket. I've already disabled all plugins (except woocommerce) and also tried a fresh up-to-date version of the theme and no luck. Equally, installing alternative search plugins doesn't help either as they (Swiftype & Relevant Search) don't seem to be compatible with the theme at all.

    I'll wait for Woothemes to come back to me and I'll make a post here for any others experiencing the same issue or finding the thread while looking for answers as I have now!

  11. SN0WKRASH
    Member
    Posted 1 year ago #

    I'm having this exact same problem - WooThemes Canvas - I'll log in to that support area and see what I find.

  12. meadows.pete
    Member
    Posted 1 year ago #

    I received an email from Woothemes support on 29th October suggesting that there would be a framework update available by the end of October.

    It's now the 5th November and having just checked, there doesn't appear to be a new framework available.

    :(

    I've asked for an update and I'll update you guys when I have one...

  13. meadows.pete
    Member
    Posted 1 year ago #

    Wooframework 5.5.0 has just been released, I've updated my theme and pagination of multiple worded search results is working once again :)

Topic Closed

This topic has been closed to new replies.

About this Topic