WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Search page messed up when forwarding non-SSL forced pages to HTTP (4 posts)

  1. jetlej
    Member
    Posted 1 year ago #

    Whenever I enable the option "Any page that is not secured via Force SSL or URL Filters will be redirected to HTTP", the search results page gets messed up.

    For some reason it appends 3 duplicates of the 's' parameter.

    Eg.

    https://www.moblized.com/?s=square

    will go to

    https://www.moblized.com/?s=square?s=square?s=square?s=square

    Also that seems to disable any results.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, yeah. That's kind of awkward. It's hitting a redirect loop and stopping itself. Try adding /?s= to your list of URL Filters to make that page always be secure. That should fix it.

  3. jetlej
    Member
    Posted 1 year ago #

    That worked perfectly, thank you!

  4. jetlej
    Member
    Posted 1 year ago #

    Marking resolved

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.