WordPress.org

Ready to get started?Download WordPress

Forums

Simple Intranet Directory
[resolved] search not working as expected (3 posts)

  1. egbertozanon
    Member
    Posted 1 year ago #

    Hi there, Sorry to bother you guys with this question. It might be simple to fix but I'm not a php or programmer.

    I published an intranet web site:
    the url is: http://intranet/wordpress

    The plugin works fine if I use it as a post and the post is still showing at the home page as it is recent. But when I add the shortcode [employees] to a page, example:

    http://intranet/wordpress/?page_id_293

    After I perform a search on the list it directs me to the page:
    For example:
    if I search for Adam it sends me to my home page and at the adress bar I can see that:
    http://intranet/wordpress/?si_search=adam&type=name

    I tested and if I type on my adress bar manuallly the following:

    http://intranet/wordpress/?page_id=293&si_search=Adam&type=name

    then it displays me search result.

    Can you help me with directions were and waht to add so the search send me to the right place?

    This is an intranet website so there is no way to publish on the internet...

    Best Regards

    Egberto Zanon
    [email address moderated - this forum does not provide support via email]

    http://wordpress.org/extend/plugins/simple-intranet-directory/

  2. Chris Charlwood
    Member
    Plugin Author

    Posted 1 year ago #

    Try going into your Settings / Permalinks and set them to "post name", vs showing the ID of the post... that should likely do it. If not, let me know... I've now subscribed to this thread. :)

  3. egbertozanon
    Member
    Posted 1 year ago #

    Thank you very much Chris Charlwood!!!

    By changing the permalinks it solved this issue.

    At first I was receiving a page not found but then I realized that on my apache the mod_rewrite wasn't enabled.

    So I enable mod_rewrite on apache by running:
    a2enmod rewrite

    Then I had to change the AllowOverride parameter on my 000-default file from none to all.

    Best Regards

    Egberto Zanon

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags