WordPress.org

Ready to get started?Download WordPress

Forums

search form not working (6 posts)

  1. bakeologybylisa
    Member
    Posted 6 months ago #

    Hi,

    I'm using the default search bar for the forever theme at bakeologybylisa.com with the swiftype plugin. I also use feedburner to allow people to subscribe for email updates. The problem is, when you type something into the search form and hit enter to search, it redirects to the feedburner form (so when you hit enter, a feedburner confirmation pops up). This is the code in my searchform.php file:

    <form method="get" id="searchform" action="<?php echo esc_url( home_url( '/' ) ); ?>">
    		<label for="s" class="assistive-text"><?php _e( ' ', 'forever' ); ?></label>
    		<input type="text" class="field" name="s" id="s" placeholder="<?php esc_attr_e( ' ', 'forever' ); ?>" />
    		<input type="submit" class="submit" name="submit" id="searchsubmit" value="<?php esc_attr_e( ' ', 'forever' ); ?>" />
    	</form>

    This is a problem whether or not the swiftype plugin is installed. Can anyone help me fix this?

  2. Tara
    Member
    Posted 6 months ago #

    Have you tried:
    - deactivating ALL plugins temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    - switching to the unedited default, core-bundled Theme (such as Twenty Twelve, Twenty Thirteen or Twenty Fourteen) for a moment using the WP dashboard to rule out any theme-specific issue.
    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

  3. bakeologybylisa
    Member
    Posted 6 months ago #

    Hi,

    I know that the problem is theme-specific, as in it is an issue with the way the searchform.php file is set up in my theme (forever). So I pasted the code above - I just don't know what I need to change to fix it.

  4. Tara
    Member
    Posted 6 months ago #

    I know that the problem is theme-specific

    what theme are you using?
    where did you download it from?

  5. bakeologybylisa
    Member
    Posted 6 months ago #

    Like I said, I'm using the forever theme. It's one of the free automattic themes offered by wordpress.

  6. esmi
    Forum Moderator
    Posted 6 months ago #

Reply

You must log in to post.

About this Topic