WordPress.org

Ready to get started?Download WordPress

Forums

Search form deleted by addig a post?! How so? (9 posts)

  1. andrewa.org
    Member
    Posted 3 years ago #

    I've spent all day trying to get rid of the search form in right hand sidebar of a theme. I've been using Starkers theme (latest version). I seem to have deleted it BUT had to add a post first! - read that somewhere here. How on earth does that work? Anyone shed some light on this please??!

    Thanks in advance,
    Confused Andrew

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    The cache needed updating - either at your browser's end or at your web hosts/ISP?

  3. andrewa.org
    Member
    Posted 3 years ago #

    I'm just a new newbie with WordPress. Nothing to do with my webhost/ISP. WordPress is saved locally.

  4. andrewa.org
    Member
    Posted 3 years ago #

    Furthermore, I just deleted the post and now the form appears again.

    "Not Found
    Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.
    Search for: "

    the above appears along with the search field.

    Anyone throw any light upo this for me?

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried adding an empty text widget to your sidebar? Or editing your theme's sidebar.php template file?

  6. andrewa.org
    Member
    Posted 3 years ago #

    I've no knowledge of php but I've been editing the sidebar.php and a host of other php files all day.

    How do I ad an empty Text widget then esmi?

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    If your theme is widget aware, you should be to just drop a text widget into the sidebar via Appearance -> Widgets

  8. andrewa.org
    Member
    Posted 3 years ago #

    I'll check it out. Cheers esmi for the helpful thoughts.

  9. andrewa.org
    Member
    Posted 3 years ago #

    ok, so I got rid of the post. The search bar appeared with the above text again. So then I drag and droppped a text widget via backend, Appearance -> Widgets.

    Text Widget didn't work! Damn.

    Any of thoughts?

Topic Closed

This topic has been closed to new replies.

About this Topic