WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin:All in One SEO Pack] Search engine not linking back to the correct post (5 posts)

  1. Tideas
    Member
    Posted 6 years ago #

    Hello, for some reason, the search engine (specifically google) aren't linking back to the correct page that the description is showing.

    I.e., someone searching for a best buy ads gets to see my site description, and the description is correct, but instead of linking to the URL of that posting, google just links to the main web page, http://www.project-tideas.com/

    Any suggestions?

  2. uberdose
    Member
    Posted 6 years ago #

    This is a common problem. You can remedy it with more inbound links, both to your index/main page and to the post pages. Eventually it comes down to PR (which google want you to forget). External links to your post work even better.

  3. ringostar
    Member
    Posted 6 years ago #

    I think if its a common problem it should be fixed no ? We shouldn't have to remedy the problem due to the plugins error, of course external links are the holy grail but that's beside the point, the plugin should not be causing a problem of this magnitude in the first place imho

  4. uberdose
    Member
    Posted 6 years ago #

    I don't see a way to fix that with on page factors. And it's not caused by AIOSP.

  5. kevcombs
    Member
    Posted 6 years ago #

    Landing Page Optimization is a little different from straight up SEO. A plugin won't be able to sort that stuff out for you. You need to really work a fixed landing page as if it's a separate website--it takes a while for Google to sort out that there is more than one topic on a site.

Topic Closed

This topic has been closed to new replies.

About this Topic