WordPress.org

Ready to get started?Download WordPress

Forums

Dave's WordPress Live Search
Search box just displays the 'working' icon but never displays results (6 posts)

  1. djdennisj
    Member
    Posted 1 year ago #

    Search box just displays the 'working' icon but never displays results.

    I've waited a decent time for the results so I'm fairly certain something is broken and they are never going to display. Is there something wrong with my site?

    http://www.SanDiegoCreativeMusicDJs.com

    http://wordpress.org/extend/plugins/daves-wordpress-live-search/

  2. Dave Ross
    Member
    Plugin Author

    Posted 1 year ago #

    One of your other plugins is causing this warning:

    <b>Warning</b>: array_key_exists() [<a href='function.array-key-exists'>function.array-key-exists</a>]: The second argument should be either an array or an object in <b>/home/djdennis/public_html/sandiegocreativemusicdjs.com/wp-content/plugins/hl-twitter/functions.php</b> on line <b>71</b><br />

    That displays at the beginning of the AJAX response from the server, so the search result data can't be parsed correctly.

  3. djdennisj
    Member
    Posted 1 year ago #

    That was the little bit of debug info I needed! I disabled the HL Twitter plugin and now yours is working great! Thanks.

  4. nicolesy
    Member
    Posted 8 months ago #

    I'm having this same error (icon spins but never shows any results). Is there a way to determine which plugin is causing it? Or should I just deactivate them one by one until it works?

    Here's the site where I installed the plugin: http://nicolesyblog.com/blog/

  5. Dave Ross
    Member
    Plugin Author

    Posted 8 months ago #

    Hi nicolesy,

    It looks iike a plugin or something is adding a newline character (\n) to the end of all your excerpts. This is an invalid character in JSON that most JSON parsers are willing to ignore, but jQuery rejects.

    That should be easy for me to filter out in the plugin.

    - Dave

  6. Dave Ross
    Member
    Plugin Author

    Posted 8 months ago #

    Ok, I dug into this a little more this week, and jQuery's JSON parser doesn't balk at newline characters. There has to be something else in the data returned by the DWLS back-end. Sorry I can't be any more help, but something in your content is breaking the JSON parsing, and it wasn't obvious when I looked at your site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic