WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Scrolling with mouse wheel doesn't work (8 posts)

  1. Garfinator
    Member
    Posted 1 year ago #

    Hi,

    I'm using Fancybox 1.3.4.9 to display inline content in a popup. I removed the horizontal scrollbar using "overflow-x: hidden" and "overflow-y: scroll".

    Everything works pretty well, except that vertical scrolling only works by moving the scrollbar but not by using the mouse wheel.

    For an example, go to http://www.yools.com, type "test" at the left of the red button with "Ik ben geïnteresseerd" and hit the button.

    Any idea how I can make vertical scrolling using the mouse wheel work?

    Thanks a lot!

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, it's the jQuery Mousewheel extension... Do you know how to hack a plugin? Of so, you can edit the main easy-fancybox.php and comment out the line where it enqueues the mousewheel.jquery script file.

    If not, you'll have to wait for the next update which will have an option on the settings page to disable that extension.

  3. Garfinator
    Member
    Posted 1 year ago #

    Hi, thanks for your reply. I had already solved the problem in the meantime by shrinking the content so that it fits in the popup window.

    However, it looks like this will be a good solution in case I need it elsewhere! Or the next plugin update of course :-)

    Thank you!

  4. fastasleep
    Member
    Posted 6 months ago #

    I was able to solve my inability to get vertical scrolling working on a large div of text by renaming the jquery.mousewheel.js and jquery.mousewheel.pack.js files, essentially disabling them.

  5. RavanH
    Member
    Plugin Author

    Posted 6 months ago #

    @fastasleep -- the current versionhas an option to disable the mousewhheel script. Look for 'mousewheel' on your Settings > Media admin page.

  6. fastasleep
    Member
    Posted 6 months ago #

    I'm using the latest — 1.5.5 — and there is no mention of "mousewheel" on the Settings page.

  7. RavanH
    Member
    Plugin Author

    Posted 6 months ago #

    You probably need to enable the default Images section first. Then the option will be visible. Disable it, save and disable Images again if you do not need that...

  8. fastasleep
    Member
    Posted 6 months ago #

    Yep, see that now. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.