WordPress.org

Ready to get started?Download WordPress

Forums

WPPizza
[resolved] Scrolling Cart Not scrolling properly (7 posts)

  1. kancancook
    Member
    Posted 6 months ago #

    I use the shortcode ( [wppizza type='cart' stickycart='1' orderinfo='1' height='300'] ) and put the ordering cart on top of the page. On the previous version, the cart would scroll down with no problem. Now, when I scroll the page down the cart would scroll down as well but it is compress to the left side. Here is the link to my site. Thank you.

    http://goodfriendgreatfood.com/our-menu/

    https://wordpress.org/plugins/wppizza/

  2. ollybach
    Member
    Plugin Author

    Posted 6 months ago #

    I can see the problem and it should get fixed in the next version in the next couple of days (alongside a couple of other issues)
    that's assuming it's not something funny going on in the theme you are using...i'll find out and report back though

    give me a day or two

    PS: although the previous version the cart might have worked just fine in your scenario, there were other issues in other scenarios.

  3. ollybach
    Member
    Plugin Author

    Posted 6 months ago #

    ok, the problem comes from an old(ish) version of jquery.
    i.e you have wordpress 3.5.2 installed, which comes with jQuery 1.8.3 (nov 2012)

    2 options :

    a) update your wordpress installation (which you probably ought to do anyway)

    b) i will see if i can make this thing work with jQuery 1.8.3. if so, it will be in the next update of wppizza.

    so if you dont want to update wordpress , wait a few days and it will be fixed (if possible)

  4. kancancook
    Member
    Posted 6 months ago #

    I don't want to update to the latest WordPress because other plugin I am using will not support it. What version of WordPress can i upgrade so I can get the necessary jQuery version. Thanks

  5. ollybach
    Member
    Plugin Author

    Posted 6 months ago #

    >What version of WordPress can i upgrade

    dunno really.
    However , the next version of wppizza will also work with yours (i made a couple of changes so this will work with older jQuery too)

    just be patient for a couple of days, update wppizza as normal and it will work (i tested it here with your theme and WP 3.5.2 and its fine)

  6. ollybach
    Member
    Plugin Author

    Posted 6 months ago #

    scrolling cart should now also work with older versions of jQuery in v2.8.8

  7. kancancook
    Member
    Posted 6 months ago #

    Thanks very much. Got it installed and it work great.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.