WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] Scripting Guard (3 posts)

  1. yamaden
    Member
    Posted 1 year ago #

    When I see localization page, it keep showing that "The Plugin Codestyling Localization was forced to protect its own page rendering process against 16 incidents !"

    Here is a screenshot of it.

    http://imgur.com/KBR3R

    This might be because I changed My wordpress's language code from "ja.mo" to "ja_JP.mo" (otherwise, it was never translateed.)

    I don't know what I should do with this. Could you help? Thanks!

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    There are a lot of different issues contained:

    1.) The PHP notice warning within adsense-plugin results from not existing key inside the plugins own options. The author missed to test the existence of it's values. Please inform the author of adsense-plugin about.

    2.) The PHP warning within my plugin was raised because of active ja_JP.mo and is indeed a bug within my plugin in context of special languages. This will be repaired with version 1.99.30 soon.

    3.) The misplaced core file enqueue of media upload script is caused by the active theme as I can investigate it. The Theme author is attaching this script into all backend pages but should it only attach to it's own backend pages where needed. Please contact the Theme author about.

    4.) Furthermore the Theme enqueued a second script out of it's own hosted scripts for assisting media upload as portfolio-upload.js Please contact the author of Theme to restict the script attachment to Theme based backend pages only.

    5.) A plugin or the Theme tries to attach a jQuery version from Google CDN provider instead of using the WordPress shipped version of script. This has been remove at my plugins backend pages to avoid conflicts. I can't find out, which plugin or theme is responsible for. The responsible author should be informed about it.

    6.) Reporting the scripts from jetpack WordPress CDN as dubiouse external is not longer the case, I'm afraid, you are not using the latest version of my plugin. It will be reported as supported CDN but with hints since latest versions.

    Hope this may explain it more in detail.

  3. yamaden
    Member
    Posted 1 year ago #

    Thank you for your quick and detailed reply. I will do what you suggest and contact you again if necessary. Thank you and have a wonderful holiday!

    Yamaden

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.