WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate TinyMCE
[resolved] Script running with this plugin sending spam (11 posts)

  1. ritalmclelland01
    Member
    Posted 11 months ago #

    I keep getting the following error message on my server:

    [06-May-2013 04:55:56] PHP Warning: file_get_contents() [function.file-get-contents]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/XXXXXX/public_html/XXXXXX/wp-content/plugins/ultimate-tinymce/includes/jwl_rocket.php on line 21
    [06-May-2013 04:55:56] PHP Warning: file_get_contents(http://www.soizastudios.com/rocket/output.txt) [function.file-get-contents]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/XXXXX/public_html/XXXXX/wp-content/plugins/ultimate-tinymce/includes/jwl_rocket.php on line 21

    What is this crap here that your script is trying to open?

    file_get_contents(http://www.soizastudios.com/rocket/output.txt)

    http://wordpress.org/extend/plugins/ultimate-tinymce/

  2. Josh (WP Edit)
    Volunteer Moderator
    Plugin Author

    Posted 11 months ago #

    You can disable it by un-checking the "Support the Developer" option in the Ultimate Tinymce settings page.

    EDIT: Are you using the most recent version of the plugin? Version 4.5?

  3. Marventus
    Member
    Plugin Author

    Posted 11 months ago #

    Hi.

    What is this crap here that your script is trying to open?

    It's not "crap": it's a list of urls for the "Support the dev" feature, which is completely opt-in and can be disabled.
    There's nothing spammy about it.
    In the future, please refrain from using foul language when asking people for help.
    Thanks!

  4. You can disable it by un-checking the "Support the Developer" option in the Ultimate Tinymce settings page.

    Josh, that should be an "you can enable this by checking..." - Remember all this stuff has to be OPT-IN. If it's the other way around, we have a problem.

    edit: Looks like the current version did that. OP, make sure you upgrade please :)

  5. Josh (WP Edit)
    Volunteer Moderator
    Plugin Author

    Posted 11 months ago #

    Thank you, Ipstenu.

    Yes, I want to be very careful to maintain myself within WP guidelines.

    It is purely optional.. and has an option to disable completely.

  6. ritalmclelland01
    Member
    Posted 11 months ago #

    I do not see a "support the dev" or "Support the developer" in my settings so where do I turn it off.

    In the future, please refrain from using foul language when asking people for help.

    Was not aware that I used foul language unless the word "crap" is considered foul if so I apologize.

  7. ritalmclelland01
    Member
    Posted 11 months ago #

    Okay have updated to latest version and still can't figure out how to turn if off. If you notice on the screen capture I am not given an option to check or uncheck. I am also getting a pop-up now for adjusting setting to beginner, intermeditate, advanced but know matter which selection I select nothing happens and the pop-up stays on the screen.

    http://screencast.com/t/R91Dauy0xt

  8. Josh (WP Edit)
    Volunteer Moderator
    Plugin Author

    Posted 11 months ago #

    You are missing all of the checkboxes.

    Look throughout the admin settings page for Ultimate Tinymce.

    Do you see any checkboxes anywhere? I don't see any in your screenshot.

    Are you using the IE browser? Perhaps try a different browser to see if the checkboxes become available.

    EDIT: Please also manually empty your browser cache. You might still have the old version cached. If you don't know how, Google can be your friend :)

  9. It is purely optional.. and has an option to disable completely.

    Josh - Other way around.

    Enable means "I have the power to turn this on if I want to."

    Disable means "You turned this on for me, but I can turn it off."

    Opt IN means you have to let people ENABLE it. Your plugin, right now, activates the option by default, so I have to disable it. Please change that right away. The option MUST be turned off by default. This is not negotiable.

  10. ritalmclelland01
    Member
    Posted 11 months ago #

    You are missing all of the checkboxes.

    EDIT: Please also manually empty your browser cache. You might still have the old version cached. If you don't know how, Google can be your friend :)

    Was using chrome, cleared cache works fine now thanks!

  11. Josh (WP Edit)
    Volunteer Moderator
    Plugin Author

    Posted 11 months ago #

    @ ritalmclelland01,

    You are welcome.

    (This topic has been resolved)

Reply

You must log in to post.

About this Plugin

About this Topic