WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] Script guard update (7 posts)

  1. ceslava
    Member
    Posted 1 year ago #

    Hi,

    I just resolved the problem with Avada Theme but the script guard alert still shows and the theme translation is deactivated.

    Should I see the database in order to restore the plugin?

    Thanks.

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    I do not understand, what you try to explain. I have tested Avada Theme at my local install and it can be translated even if there are Scripting Guard warning about PHP issues of type STRICT.
    I don't get any other problem, could you please descibe your problem more in detail?

  3. ceslava
    Member
    Posted 1 year ago #

    Sorry for my bad english, the script guards alerts about a script which I have removed here:

    PHP runtime error reporting detected !
    Reason: some executed PHP code is not written proper | Originator: desconocido (probably by Theme or Plugin)
    Below listed error reports has been traced and removed during page creation:
    NOTICE Error: [8] Undefined property: kdMultipleFeaturedImages::$args /home2/nhdsemwe/public_html/wp-content/themes/Avada/framework/plugins/multiple-featured-images/multiple-featured-images.php on line 69

    And the theme shows as deactivated

    Avada © ThemeFusion

    Textdomain: Avada
    Versión: 2.0.3
    Estado: desactivado

  4. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I've tested 1.0.8 (free version), may be a lot differences.
    Would it be ok, if you could provide the Theme for testing purpose by mail (can be found at my imprint page)?

  5. choegl
    Member
    Posted 1 year ago #

    Same problem for me, using the most recent Avada theme 2.0.6

  6. ceslava
    Member
    Posted 1 year ago #

    Hi choegl,

    The great Haiku resolved the problem with this theme vía email.

    His solution:

    If a child theme is active and it doesn't load any own translation, the main theme will still load the translations but will appear as deactivated.

    The error listed is caused by a wrong implementation within the multiple-featured-images.php file line 69. Currently this is:

    $this->nonce        = 'mfi-'.$this->args['id'].$this->args['post_type']; 
    
    but should be 
    
                $this->nonce        = 'mfi-'.$this->id.$this->post_type;

    I also commented out these lines to avoid the warning

    public function kd_admin_init() {
            /* translation problem
                       wp_enqueue_script(
                      'kd-multiple-featured-images',
                      get_bloginfo('template_directory').'/framework/plugins/multiple-featured-images/js/kd-admin.js',
                      'jquery'
              );*/
          }

    Thanks again to Haiku for this great plugin and for his great and fast support.

  7. choegl
    Member
    Posted 1 year ago #

    It works!

    What a relief! I had been dealing with this for hours.

    Thank you! Thank you! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic