WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Screwing up permalinks? (6 posts)

  1. seregon
    Member
    Posted 2 years ago #

    The only options I have enabled with this plugin are Shared SSL & Force Admin SSL, because all I wanted it for is to log in and use my admin securely without having to purchase private SSL.

    But it seems to be tampering with permalink settings, and I can't figure out what for. It's also tampering with them in such a way that they're never going to work at all.

    Basically, it's forcing the "Custom" setting. If I change it, it changes back. And the custom setting it's forcing is nonsense:

    [Shared_SSL_prefix]%year%/[Shared_SSL_Prefix]%month%/[Shared_SSL_Prefix]... etc.

    This results in a nonsense URL like:

    https://my.site.com/blog/year/https://my.site.com/blog/month/https://...

    What's going on? And how do I fix it?

  2. seregon
    Member
    Posted 2 years ago #

    UPDATE

    Temporarily disabling both the Shared SSL options allowed me to set my permalinks back the way I wanted, which continued to "stick" after I re-enabled them.

    I'm not sure how permanent this workaround is yet, though it's working so far. I also don't suspect this would work if I were using custom permalink settings, because I believe they would be overwritten by the garbage settings I noted above.

    It's also a bit of an annoying workaround if you ARE on SSL, because you have to navigate the dashboard with no CSS unless your browser's cache saves you!

  3. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Seregon,

    I'm pretty sure I know what's causing this. The plugin has a filter in it to find any relative paths in certain elements and upate them to the Shared SSL URL when using Shared SSL. This filter is running on input fields when it really doesn't need to unless the input field is an image. I'll put a fix into the next release.

    Thanks,
    Mike

  4. seregon
    Member
    Posted 2 years ago #

    Mvied:

    That sounds reasonable. Naturally, I'm not all that familiar with WordPress yet or how your plugin works, but your solution sounds intuitively correct. I look forward to the fix, particularly as letting the public on my shared SSL could be somewhat of a security risk.

    (The URL for my shared SSL is https://secure.webhost.com/~username/, where that username cannot be changed and can be used for several different kinds of access.)

  5. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey seregon,

    This is confirmed fixed in 1.9.2. Please update and let me know if it's fixed for you.

    Thanks,
    Mike

  6. seregon
    Member
    Posted 2 years ago #

    I can confirm this is fixed for me in 1.9.2, and it's being more stable in general with my SSL. Excellent, excellent work & many thanks. I have updated the other thread as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic