WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Screwed Up My Tag Cloud, Somehow (5 posts)

  1. cspowers
    Member
    Posted 1 year ago #

    I've got 3.5 on two separate WP installs. One is a sandbox and one is production.

    On my production system I'm using widgets on pages to create a widget area on a page. I've dropped the tag cloud widget on the widget area. Seems to work ok.

    BUT it only shows tags for which more than one post has that tag. If a tag is on only one post, it does not show up in the tag cloud. If it is on two or more posts, it shows up in the tag cloud. On my production systems I have some where in the order of 100-125 tags and about 200 posts.

    What I'd like to see is all tags that have one post or more so the tag cloud becomes sort of an index page.

    I installed the ultimate tag cloud plugin and (I think) set it up so that a tag shows up if there is at least one post with it. But STILL the tag has to be used on at least two posts before it shows up, despite the configuration in the Ultimate Tag Cloud widget.

    So that's two different tag cloud widgets exhibiting the same behavior.

    So I went to my sandbox system which is using the same theme (Genesis eleven40). My sandbox system does NOT exhibit this behavior. On the other hand it's only got about 10 posts and three tags.

    So my question is, is there any other way that WP could be setting the minimum number of posts to cause the tag to display? And if so, how to I override it?

  2. Tara
    Member
    Posted 1 year ago #

    First off, to rule out any theme-specific issue, try switching to the unedited default twentytwelve theme for a moment using the WP dashboard. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes via FTP or SFTP or whatever file management application your host provides.

  3. cspowers
    Member
    Posted 1 year ago #

    Update: Seems like I was somewhat mistaken. It doesn't seem to have anything to do with the number posts associated with the tag.

    But the problem remains. Some tags are showing up in the tag cloud and others aren't. So far I can't figure out any pattern as to why a tag does or does not get included.

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    there is a default limit of 45 tags for the default tag cloud widget;

    overwrite this with a little added code in functions.php of your theme:

    add_filter('widget_tag_cloud_args','set_tag_cloud_parameter');
    function set_tag_cloud_parameter($args) {
    $args = array('number' => 200, 'largest' => 22);
    return $args; }

    (the second parameter is only to show how to use more than one parameter in the code)

    you can use all the parameters from:
    http://codex.wordpress.org/Function_Reference/wp_tag_cloud

  5. cspowers
    Member
    Posted 1 year ago #

    *headslap*

    did some reading around, and found out that WP limits tags to 45 unloess the limit is overridden. That's what my problem was. I used the ultimate tag cloud widget which let me set the limit to what i wanted. I set it to 999 and everything showed up just fine.

    Sorry for the false alarm. That's the first time I ever realized there was a limit.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags