WordPress.org

Ready to get started?Download WordPress

Forums

ScrapeAZon
ScrapeAZon reviews not displaying on page (27 posts)

  1. kkt300sl
    Member
    Posted 2 years ago #

    Product reviews are NOT displaying on my page. I had double checked my ScrapeAZon settings and everything is correct (I am also using the same Amazon settings for Two Click Mall plugin and it is retrieving data just fine).

    I only entered short code for products that currently have customer reviews, so I know that is not an issue.

    Please advise.

    My site is http://michaelkorsaccessories.com/ and the reviews should be showing up on this page: http://michaelkorsaccessories.com/product-reviews/

    Thanks - Kimberly

    http://wordpress.org/extend/plugins/scrapeazon/

  2. jhanbackjr
    Member
    Plugin Author

    Posted 2 years ago #

    Hello, Kimberly.

    If you view the source code of your product-reviews page, the following HTML comment is present:

    "A valid ASIN was not provided or ScrapeAZon is not properly configured."

    This error typically occurs when there is a problem with the ASIN you provided in the ScrapeAZon shortcode. A typical ScrapeAZon shortcode should resemble the following:

    [scrapeazon asin="0123456789"]

    Double-check the ASIN to ensure that there are no extraneous characters or spaces in it. If you still have problems, send me a sample ASIN and the shortcode you are using to call it. I'll test it on my side.

    Thanks for trying ScrapeAZon.

    James

  3. SequimPC
    Member
    Posted 2 years ago #

    It is the same for me, I have the latest version of both wordpress and scrapeazon and all my information is correct in scrapeazon and my shortcode is correct but it is not displaying the reviews at http://01tech.net/tech/say-goodbye-to-dust-off-forever-ed500-from-metro-vacuum-is-amazing/ I love the idea of this plug-in and would love to have it working.

  4. jhanbackjr
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, SequimPC.

    Verify that you typed the shortcode in HTML mode in the WordPress editor, not VISUAL mode. If you typed the shortcode in VISUAL mode, characters such as quotation marks will have been converted to HTML escape codes and the shortcode will not function properly.

    Thanks and let me know if I can be of further assistance.

    James

  5. SequimPC
    Member
    Posted 2 years ago #

    James, I cut the shortcode from my post in visual mode, pasted it into HTML mode and refreshed the page and it still is giving me the same results. I even deleted the HTML entry and hand typed it for good measure.

  6. jhanbackjr
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, SequimPC.

    Do you know if you're using any kind of caching that might be showing you an earlier version of your page? If you are, try clearing the cache (including in your browser) and see if that does it.

    If it doesn't, would you mind posting the shortcode you are attempting to use? That way I can test it on my end and see if I can reproduce the problem.

    Thanks!

  7. SequimPC
    Member
    Posted 2 years ago #

    Thank you for your attentiveness to this issue, the short code is: [scrapeazon asin="<B001J4ZOAW>"]

  8. jhanbackjr
    Member
    Plugin Author

    Posted 2 years ago #

    No problem at all. I see the issue now. Try pasting the following shortcode in HTML mode:

    [scrapeazon asin="B001J4ZOAW"]

    That should do it. The problem is you had pasted it with the < and > symbols surrounding the ASIN.

    I can understand the confusion. I use the < and > symbols in the FAQ/usage to "contain" the "ASIN or 10-digit ISBN" language. They're not meant to actually be included in the shortcode. I should probably change the FAQ to make that less confusing.

    In any event, I tested [scrapeazon asin="B001J4ZOAW"] in my own environment and received immediate results, so it should work for you as well.

    Let me know if this solves the issue! If it doesn't, I'll take another stab at it.

    Thanks.

    James

  9. SequimPC
    Member
    Posted 2 years ago #

    Okay! You are awesome, it is working. Just one more thing, can you tell me how to put this into CSS:
    border="false"
    width="80"
    height="400"

    And what file or folder is this going to be saved as?

  10. jhanbackjr
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, SequimPC.

    Great! I'm glad you got it working. On the CSS, you can either include the style information using the shortcode, or you can edit your WordPress theme's CSS file or add the CSS inline in your template files.

    To use the shortcode, do the following:

    [scrapeazon asin="B001J4ZOAW" border="false" width="80" height="400"]

    To do the same thing in CSS, look in the WordPress Themes folder, locate your theme, and then locate the "style.css" file.

    Make a backup copy of the style.css file before you change anything, just in case.

    Next, copy/paste the information below directly into that file. Then save the file and refresh your page. You might need to clear your browser's cache to see the changes. Here's the CSS (make sure you copy from the beginning dot all the way to the ending bracket:

    .scrapeazon-reviews {
    border: 0;
    width: 80px;
    height: 400px;
    }

    I should point out that this CSS might not remove the frame border from some versions of Internet Explorer.

    Hope that helps!

    James

  11. SequimPC
    Member
    Posted 2 years ago #

    Wow, absolutely amazing! Thank you for your help, it is a truly great amazon review app! Here it is working great: 01Tech.net

  12. bregister555
    Member
    Posted 1 year ago #

    I'm having a similar problem, for me I put in the short code:
    [scrapeazon asin="0615492428"]
    I input the short code in the "text" not "visual" tab.

    When I preview the page:

    http://www.frontgateliving.com/amazonreviews/

    I see no code for ScrapeAzon. I've put in the Key, secret Key and the associate ID. (The associate ID is in the form...XXXX-XXXX-XXXX, is that right?

    Anyway, I don't see what is wrong and I've tried putting in the [gallery] short code and it works fine...

    Any help would be GREATLY appreciated.

    Thanks!

  13. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hello, bregister555.

    What version of ScrapeAZon are you using? When I view the source code of the page you posted above, I do not see any HTML comments, divs, or iframe code that suggest that ScrapeAZon is activated on your site. Normally, if ScrapeAZon is correctly installed and activated, you should at least see an HTML comment in your page's source code that indicates an error if you do not see content.

    Also your Amazon associate ID is not necessarily in the format you specified in your post. it's the ID Amazon assigns you when you register for the affiliate program, which you can do here:

    https://affiliate-program.amazon.com/

    If you are using your correct amazon associates ID, you might try temporarily turning off or clearing any caching on your site to determine if you're seeing an older version of your page.

    When I tried the shortcode [scrapeazon asin="0615492428"] on my test site, I was able to see the first three of seven reviews.

    Let me know if I can be of further assistance, and thanks for trying ScrapeAZon.

    James

  14. bregister555
    Member
    Posted 1 year ago #

    Hi James,

    Thanks for getting back with me so quickly!

    The version number is 1.0.7, it is activated.

    I could try deactivating it, deleting it, then reinstalling...

    I noticed the same thing you did, nothing appears in the code on the page...weird.

  15. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hello, bregister555.

    No problem. If deactivating, deleting, and reinstalling does not work, you might verify that the IDs you entered on the settings page are correct.

    Another possibility is that your PHP/server installation doesn't support cURL, which is the default method ScrapeAZon uses to retrieve data from the Amazon API. If your installation does not support cURL and PHP errors are suppressed, you might not see any output in the HTML source.

    You could try disabling cURL and using file_get_contents instead by selecting the checkbox beside the cURL errors message on the ScrapeAZon settings page.

    Hope that helps. Let me know how it goes.

    James

  16. bregister555
    Member
    Posted 1 year ago #

    Well, I think I had the wrong ID... corrected that with the Tracking ID, mine ends with a -20.
    I also deleted the plugin and reinstalled.

    No Dice.

    I then tried the plug in with that cURL check box enabled and disabled, neither did anything. It's unchecked now.

    Checked the PHP on my host server...

    it says:

    PHP 5.2 (this one is selected)
    All files with the extension .php will be handled by the PHP 5.2 engine.
    Legacy PHP with security updates. Compatible with most environments.
    PHP 5.2 (Single php.ini)
    Same as PHP 5.2, but all subdirectories will use ~/public_html/php.ini
    PHP 5.2 (FastCGI)
    All files with the extension .php will be handled by PHP 5.2 FastCGI processes.
    FastCGI for PHP makes all your PHP applications run through mod_fastcgi instead of mod_suphp. This eliminates the overhead of loading the PHP interpreter on every hit. Since it is always in memory ready for the next hit, the responses will be generated faster.
    PHP 5.3
    All files with the extension .php will be handled by the PHP 5.3 engine.
    Most reliable and compatible version of PHP.
    PHP 5.3 (Single php.ini)
    Same as PHP 5.3, but all subdirectories will use ~/public_html/php.ini
    PHP 5.4
    All files with the extension .php will be handled by the PHP 5.4 engine.
    Latest version of PHP.
    Note: Zend Guard Loader currently not supported.
    PHP 5.4 (Single php.ini)
    Same as PHP 5.4, but all subdirectories will use ~/public_html/php.ini
    Additional extensions available for Installation
    Http
    Imagick
    Magick Wand
    Mail Parse
    OAuth
    OCI8
    Upload Progress
    IonCube
    SourceGuardian

    Not sure why I get nothing at all...maybe I need to select a different PHP?

  17. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hello, bregister555.

    I'm glad you found the correct affiliate ID.

    At this point, I suspect that it is an issue with the PHP configuration. It is possible that cURL is not installed/enabled and that file_get_contents is configured to not return information from a URL.

    I don't think I've ever tested ScrapeAZon on PHP 5.2, so I can't say for certain whether there are issues there. You could try switching to 5.3, testing, and then switching back to 5.2 if 5.3 breaks other things.

    You might also try asking your hosting provider whether cURL is available in your configuration. If they do not offer cURL, ask if allow_fopen_url is enabled. Preferably, they would have cURL enabled and allow_fopen_url disabled. If neither of those options are available to you, you will not be able to use ScrapeAZon.

    Hope this helps. Let me know how it goes.

    James

  18. bregister555
    Member
    Posted 1 year ago #

    Hi James, I sent an email to Hostmonster and here is there response...

    "Thank you for contacting Support. cURL is available on the server for use. We have PHP versions 5.2, 5.3, and 5.4 What in particular are you needing help with? We are not developers nor scripters, so I don't know any of the other requirements of this script. I would consult this data with the developer."

    So it looks like cURL is available. I've tried 5.2, and 5.3 of PHP. I switched to 5.4 and wordpress would not log in.

    Is there something I need to do to use cURL? Seems like something that should just work...

    Mike

  19. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Mike.

    You are absolutely right. There shouldn't be anything else you need to do. I noticed that the response from Hostmonster was that "cURL is available on the server for use." So it is available, but is it enabled for your particular instance of PHP?

    Assuming it is enabled, my next step would be to try to recreate your environment in a test environment and see if I can reproduce the problem on my end. For that, I would need the following information:

    1. The version of WordPress you are using
    2. A list of the themes you have installed (identifying the active one)
    3. A list of the plugins that you have you installed and activated
    4. The version of PHP you are currently using (i.e. 5.2.x, 5.2.x suhosin, 5.3.x, 5.3.x suhosin)

    If you don't want to post those in the forum, you can email them to me privately by visiting the contact form on my site: http://timetides.com/contact

    Once I've recreated your environment, I can try to duplicate the problem and will probably have more luck tracking down any issues.

    Thanks and let me know.

    James

  20. bregister555
    Member
    Posted 1 year ago #

    1. WordPress is version 3.5.1

    2. The site uses the Thesis Theme

    3. I've deactivated all of the plugins except for ScrapeAzon, if they're still installed can the still create conflicts? (My wife has a BUNCH of plugins installed)

    4. I've tried every version of PHP on Hostmonster... 5.2, 5.2 Single php.ini, 5.2 FastCGI, 5.3, 5.3 Single php.ini, 5.4, and 5.4 Single php.ini

    I just tried switching themes, no dice.

    It's a weird deal. I guess I'm not sure my Amazon Associate ID is correct yet, I've entered it with and without the -20, which is correct?

  21. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Mike.

    Thank you for the information.

    I believe that your affiliate ID is probably correct (with the -20 on the end). Even if it wasn't, the most likely behavior ScrapeAZon would exhibit would be to display the reviews and provide an incorrect affiliate ID in the links the reviews displayed.

    Additionally, if your AWS Access Key ID is incorrect, you should see an Amazon-generated message that says something like this: "InvalidClientTokenId: The AWS Access Key Id you provided does not exist in our records."

    If your AWS Secret Key is wrong, ScrapeAZon should display an Amazon-generated message that says something like this: "SignatureDoesNotMatch: The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details."

    I must admit that I'm a little perplexed by the fact that you're not seeing any output at all, especially if every other plugin has been disabled and you've tried switching themes. I'm going to go ahead and set up a test environment to see if there's anything I can do to replicate the behavior.

    Out of curiosity (and so I can most closely replicate your settings), what do you have the Country Code drop-down set to in ScrapeAZon Settings?

    Thanks.

    James

  22. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Mike.

    In my test environment, I was able to replicate the problem you are having in two separate ways:

    1. When I disabled allow_fopen_url in php.ini and enabled the checkbox in ScrapeAZon's settings
    2. When I disabled cURL in php.ini and disabled the checkbox in ScrapeAZon's settings

    Therefore, it sounds like your hosting provider might not have cURL enabled for your PHP instance, even though they have it available for use. I'd recommend checking with them again to verify that your instance of PHP actually has cURL enabled.

    You can also verify it for yourself by using the phpinfo() function of PHP. The following page describes this process:

    http://codex.wordpress.org/Finding_Server_Info

    If you scroll to the curl section of the phpinfo page that you create using the instructions at the above link, you should see a "curl support" row. If the "curl support" row is not there or does not say "enabled," then cURL is not enabled.

    I hope that helps. At this point, it's definitely looking like a PHP configuration issue.

    Please let me know if I can be of further assistance.

    James

  23. bregister555
    Member
    Posted 1 year ago #

    http://www.thegenesischronicles.com/phpinfo.png

    Looks like it's installed.

    Sort of at the end of the line with this one. Not sure why it's not working...And need to get moving on this site. Maybe we should just throw in the towel.

    I do appreciate your help with this James, you've gone above and beyond the call of duty here.

  24. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Mike.

    I'm sorry it didn't work out. That is both frustrating and perplexing.

    I am planning to add new troubleshooting features to both ScrapeAZon and GoodReviews in future releases that will, at the very least, aid in eliminating user configuration issues and cURL support as causes of problems like this.

    Perhaps we can try again when I have those routines implemented.

    Thanks for trying ScrapeAZon.

    James

  25. bregister555
    Member
    Posted 1 year ago #

    Hi James,

    Well, I've couldn't leave well enough alone and my son is helping me to run a couple of tests.

    We tested the If statement in the plugin and the result was that the function comes up false. Here's what we did...

    if (is_admin()) {
    add_action('admin_menu','scrapeazon_admin_add_page');
    add_action('admin_init','scrapeazon_register_settings');
    echo "This function is working";
    }
    else {
    echo "This function is not working";
    }

    Turns out that the function is not working. Does this help?

    We just really want this plugin to work :)

    Mike

  26. jhanbackjr
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Mike.

    The only thing the is_admin() function does is return "true" if the current page the user is viewing is a dashboard/admin page and "false" if it is not.

    http://codex.wordpress.org/Function_Reference/is_admin

    If you can see the ScrapeAZon Settings page when the plugin is activated, that's doing what it's supposed to do.

    If you still have your phpinfo() page available, look there for the following variables and let me know what their values are:

    1. disable_functions
    2. allow_url_fopen

    Also, I have nearly completed a new routine for a ScrapeAZon revision that can assist in the process of elimination for this situation. You can send me an e-mail through my contact form ( http://www.timetides.com/contact ) if you'd like to try this new version. It's not quite ready to release to the repository yet.

    Thanks and let me know.

    James

  27. bregister555
    Member
    Posted 1 year ago #

    Success!

    The Plugin works flawlessly. Ends up I went through some forums where people have the exact same issue and I had used a different login for the Product API account than I used for the AWS account (signed up at different times, thus the accounts were not related... All is fixed now.

    Thanks James, creator of this very useful plugin, for all your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags