WordPress.org

Ready to get started?Download WordPress

Forums

Scheduling posts in advance isn't working (13 posts)

  1. talia
    Member
    Posted 5 years ago #

    We have a thread in troubleshooting on this problem which affects V2.5 and 2.6 but as it is a bug I thought I'd post a link here and see if the developers could get involved in fixing it for a future version as it is critical for those of us who don't want to be online all the time posting things.

  2. valuxes
    Member
    Posted 5 years ago #

    I am running v2.6.1 and don't seem to have a problem scheduling.

    - I create a post and save, but do not publish, it.
    - I edit the date and future date it (in this test, only the time is set to 2 mins in the future).
    - I publish it.

    - It does not display, which is as it should.
    - 3 mins later (probably a date synch problem with server), the post displays when I refresh the page

    - I go back to Manage Post and re-edit the post to 2 mins in future. Save.

    - Again, post does not display anymore, which is as it should.
    - @ 3 mins later, the post displays when I refresh the page

    V

  3. talia
    Member
    Posted 5 years ago #

    someone suggested that it is an incompatibility with some hosting companies. there are a lot of us affected and it is a major problem

    i am with bluehost. who are you with?

  4. valuxes
    Member
    Posted 5 years ago #

    I'm using a dedicated server. If it's a server problem, there's probably nothing WP can really do... :(

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Some hosts have problems with the current way wp-cron operates. 2.7 *may* improve this a bit for certain known edge cases, but for others, it won't.

    One of the most common issues I've seen is hosts that cannot connect back to themselves. WordPress *needs* to be able to perform a socket connection back to itself, to run the wp-cron script asynchronously. Sometimes this is bad DNS settings (host can't look up its own host name correctly), sometimes it's a network issue (lookup resolves to external address and can't loopback), sometimes it's a server setup issue (server configured to not accept loopback connections or has an overly aggressive security configuration).

    Regardless, it's *always* a server problem. So WordPress can only do so much to help here.

    My advice: Switch hosts. Life is too short to deal with crap hosting.

  6. talia
    Member
    Posted 5 years ago #

    My advice: Switch hosts. Life is too short to deal with crap hosting.

    I'm with bluehost and when I chose them they were on the RECOMMENDED list of hosts by wordpress. Why are they on that list if they are crap hosts?

    And more importantly what can I do to fix this? I've paid for 2 years hosting and this is an important issue. I desperately need to be able to schedule posts in advance

  7. talia
    Member
    Posted 5 years ago #

    Also, if it is a hosting problem why is this only a problem in 2.5 and 2.6 but not earlier versions?

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Why are they on that list if they are crap hosts?

    I can't answer that. I don't control that list.

    Also, if it is a hosting problem why is this only a problem in 2.5 and 2.6 but not earlier versions?

    Version 2.1 changed future posting to use wp-cron, so any version since then would be affected if it is a problem with your web server.

    You can verify that wp-cron isn't kicking off properly by looking at the content of the cron option in the options table. That's where the cron jobs live. There's also a good plugin called WP-Crontrol that will show them to you as well as let you manually kick off those jobs and so forth.

  9. talia
    Member
    Posted 5 years ago #

    Thanks otto

    ummm where do I find the options table? I don't see it on my wp dashboard so I guess you're talking about somewhere else? I installed wp using fantastico. I'm not sure if that makes a difference

    I'm going to write to bluehost and see if they're aware of this as a known problem

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Forget the options table. If you don't know what I'm talking about, then you wouldn't understand the result anyway.

    Look at the WP-Crontrol plugin. That will present it in a nice interface for you.

  11. talia
    Member
    Posted 5 years ago #

    thanks otto. will do that over the weekend.

    sent an email to the helpdesk at bluehost but haven't had a reply yet. they're normally very prompt. hopefully they will get back to me soon

  12. talia
    Member
    Posted 5 years ago #

    otto I got a reply from bluehost. they said that the cron job to run the auto scheduling has never been set up in my wordpress installation. i used fantastico to do it, so i guess it's not part of that.

    can you please tell me where i find the code/instructions for the cron job so i can install it in the cron job manager?

  13. wild_eep
    Member
    Posted 5 years ago #

    It's also worth noting that version 4 of the bSuite plugin makes use of the wp-cron system in order to analyze traffic statistics.

    If wp-cron isn't firing (for whatever reason), your stat reports are empty, even though the hits are still being recorded.

    I'm hosted by adhost.com, and I'm waiting for them to contact me about this issue.

Topic Closed

This topic has been closed to new replies.

About this Topic