WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] Scheduled scans hang after 3.5.1 upgrade (6 posts)

  1. sephage
    Member
    Posted 1 year ago #

    Since upgrading to 3.5.1, manual scans run fine, but scheduled scans hang nearly every time. Usually during the malware check, about 50% through the files. I have to manually kill the scan each time, then run the scan manually and it works. Have tried upping the max execution from blank to 30 (didn't work) and now trying 60. Any thoughts?

    http://wordpress.org/extend/plugins/wordfence/

  2. Wordfence
    Member
    Plugin Author

    Posted 1 year ago #

    Try a shorter time on the max execution, like 10 or 15 seconds.

    Also let me know if it hangs at the same place each time.

    Regards,

    Mark.

  3. sephage
    Member
    Posted 1 year ago #

    Will do. It does hang at b the same place, when scanning for malware.

  4. sephage
    Member
    Posted 1 year ago #

    OK, lowering that threshold isn't working now even for manual scans. It hangs at about 475 mob into the malware portion of the scan :-(

  5. vauneen
    Member
    Posted 1 year ago #

    Hi,

    I'm having a similar issue: I upgraded WP to 3.5, then installed Wordfence 3.5, and my manual scans 'hang' every time.

    Perhaps my site is too big? is there a size your plugin starts to struggle with?

    It hangs at about 10 000 files.
    [Jan 18 11:23:05] Analyzed 10900 files containing 478.62 MB of data so far

    It hangs while simultaneously doing these 4 tasks:
    [Jan 18 11:11:50]
    Comparing core WordPress files against originals in repository
    [Jan 18 11:11:50]
    Comparing open source themes against WordPress.org originals
    [Jan 18 11:11:50]
    Comparing plugins against WordPress.org originals
    [Jan 18 11:11:50]
    Scanning for known malware files

    Any suggestions?

    Thanks,
    Vauneen

  6. Cheryl Fahling
    Member
    Posted 1 year ago #

    These two items are "stuck" in my initial scan hours later. It happened the first time I tried too, but I killed the scan.

    "[Apr 21 07:01:00]
    Scanning file contents for infections and vulnerabilities

    [Apr 21 07:01:00]
    Scanning files for URLs in Google's Safe Browsing List"

    I've registered for the Wordfence forums, but don't see a search there. Makes them hard to use. Have to browse through pages and pages of posts to find what I might be looking for.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic