WordPress.org

Ready to get started?Download WordPress

Forums

Scheduled posts won't publish (7 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    I recently moved my site to a new server and ever since my scheduled posts don't publish. In the Manage Posts area it still counts down to the scheduled date, but then after the date it starts counting up again. Also if I schedule a post to go up in a few hours it just publishes it right away.

    I've tried looking around here and elsewhere for answers but haven't found any. My web host is also looking into it, but hasn't found the answer yet. I've tried various edits to files and nothing seems to work. It doesn't seem to be a web host security issue, and the time on WordPress is set properly.

    If anyone here has any ideas, I would appreciate it.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Search for wp-cron related problems and solutions. If you can get your wp-cron to work, then you will get scheduled posts to work.

    Example post: http://wordpress.org/support/topic/151287

    There's plenty more dealing with wp-cron related issues.

  3. Anonymous
    Unregistered
    Posted 6 years ago #

    Ok, thanks! I'll keep searching around for that.

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    I've searched around, and all I can find are a lot of people complaining of the same problem with no real solution. I'm not a programmer so some of the fixes a little over my head.

  5. Niteblade
    Member
    Posted 6 years ago #

    If scheduling a post is troublesome, it would be nice if "post scheduling" could be turned off. At least there should be some kind of button to "publish all scheduled posts NOW!"

  6. phattrance
    Member
    Posted 6 years ago #

    i have the same problem, anyone have a solution yet? any plugin that can fix this?

  7. spiralof5
    Member
    Posted 5 years ago #

    yes I have the solution.
    Websites will put a file called index.html so that when you go to the site with nothing there it will say something like "if you are seeing this message you are successful"

    Index.html overrides the index.php.

    Go to your ftp via fetch and delete the index.html. Now your index.php should take over and you'll be good to go. It won't take care of the scheduling problem which is being a pain in my buttocks.

Topic Closed

This topic has been closed to new replies.

About this Topic