WordPress.org

Ready to get started?Download WordPress

Forums

Scheduled Posts Not Working Since 2.9 (15 posts)

  1. bkushner
    Member
    Posted 4 years ago #

    Since upgrading to 2.9 my scheduled posts are not working. How do I roll back to previous upgrade. I have to have scheduled posts.

  2. yohay
    Member
    Posted 4 years ago #

    I also had this problem in WordPress 2.9. I must say that this sometimes happened in WordPress 2.8.6 as well, but it seems more frequent with the new version.

  3. Robert Chapin
    Member
    Posted 4 years ago #

    This patch is waiting for core approval now, but I wanted to put it up here in case you need it sooner than that.

    http://core.trac.wordpress.org/attachment/ticket/11505/ticket-11505-full.patch

  4. nautical4
    Member
    Posted 4 years ago #

    Yup. Same problem since I installed the new 2.9. No scheduled posts. All earlier editions worked fine for me.

  5. mbabc
    Member
    Posted 4 years ago #

    I'm curious if anyone from WordPress can give us an estimate as to when a version 2.9.1 with a fix might be available.

    Thanks!

  6. mbabc
    Member
    Posted 4 years ago #

    They only way I've found to make the entry post is to do a "New Post" and to publish immediately.

    Is there an easy way I can get the scheduled post to actually post? [Re-setting the schedule for a new date just results in another "Missed Schedule."]

  7. Jacorre
    Member
    Posted 4 years ago #

    After a schedule is missed, is there a way to publish the post immediately? There seems to be no way to remove the scheduled date/time that was previously defined and allow the post to publish at that moment?

    A workaround is copy the post then delete it. Create a new post and paste in the content then publish immediately.

  8. Jo5329
    Member
    Posted 4 years ago #

    Glad to see I'm not the only one with the problem - but sad it hasn't been fixed yet.

    Yes @Jacorre - I had to copy/paste/publish this morning.

    The best part of WP is the scheduling!

  9. Robert S
    Member
    Posted 4 years ago #

    Those of you impatient for the schedule/cron fix can always install WordPress Beta Tester plugin and install 2.9.1RC1 straight away.

    R

  10. mbabc
    Member
    Posted 4 years ago #

    I just installed 2.9.1 (it's Wednesday, January 1, 2010) and it fixes the problem.

  11. MickC
    Member
    Posted 4 years ago #

    It seems to be broken (still|again) in 3.0-alpha. Post scheduled for this morning didn't go (although Twitter Tools posted it to my stream on time -- making for a slight embarrassment).

  12. paperfinger
    Member
    Posted 4 years ago #

    I can't wait for this to be fixed.

    In the meantime, if the post misses schedule, you can change it immediately to published by clicking on the "quick edit" link in the posts list view. You have the option to change the status to "published" which does the trick.

  13. esmi
    Forum Moderator
    Posted 4 years ago #

    It was fixed in 2.9.1

  14. gravlax
    Member
    Posted 4 years ago #

    I on 2.9.2 and it's apparently still a problem.

  15. fredhead
    Member
    Posted 4 years ago #

    In the meantime, if the post misses schedule, you can change it immediately to published by clicking on the "quick edit" link in the posts list view. You have the option to change the status to "published" which does the trick.

    I wish. I'm running 3.0 on LAMP and this doesn't trick doesn't work. And of course on the Edit Post page, the publication status work needs alot of work. At the least, the Quick Edit status dropdown choices should be repeated on the Edit Post status area so people don't have to waste time searching forums. Assuming the trick works. 8-)

    I've given up and will either waste my time creating a copy of the article or do a database-ectomy and update the status manually. But no one should have to do either option. This is basic stuff.

Topic Closed

This topic has been closed to new replies.

About this Topic