WordPress.org

Ready to get started?Download WordPress

Forums

Scheduled posts not publishing (14 posts)

  1. Chris Barrett
    Member
    Posted 1 year ago #

    Hi,

    I've gone through the forums and I realize this seems to be an intermittent issue. This only started happening a few days ago, I started experiencing some problems and I'm beginning to think they are related:

    1) Scheduled Posts are no longer publishing. WP recognizes this and flags as a Missed Schedule Time. Posted are being creating in WP - not Windows Live Writer.
    2) When I manually publish the failed scheduled post to the intended URL, I could not access. Browsers (FF,Chrome & Explorer) all indicate the site has gone into an infinite loop. I don't use any redirection (plugins or at hostlevel). If I go back into WP and manually change the URL to an new address, the post works. After moving the post's URL and republishing, the old URL redirects to the very first post in that category instead of a 404 page. The original URL is not referenced in any other posts (trash is empty) so I don't understand where that redirect is coming from.
    3) Then, yesterday, I couldn't access wp-admin, but the site was still up. Got a Memory Exceeded error. Guess what? Trying that broken URL from the post that was redirecting ALSO was now giving me a Memory Exceeded error.

    I followed forum advise and FTPed all the plug-ins out, then got back into WP Dashboard. The issue appears to be with either W3 Total Cache and WP-DBManager. I've uninstalled both. Still scheduled posts won't work. Broken URL now goes back into a redirect to the very first post. You can try yourself here: http://shmortgage.com/zh-hant/2012/08/hrw-10/.

    Here is the final piece: I attempted to download into WAMPServer to see if I could figure it out. Was advised the max packet size was exceeded and couldn't import.

    The exact line is in wp_options, option_name chron. In a clean WP install, that otion_value is 805 characters in length. On my live site, it's 1,866,045 characters in length. It just repeats over and over.

    Any ideas on how to fix that?

    Thanks!

    Chrsi

  2. Steven Jones
    Member
    Posted 1 year ago #

    With the scheduling post issue, some hosts don't allow it so you'd have to setup a real cron job via your host to run wp-cron.

  3. christiang69
    Member
    Posted 1 year ago #

    Hi, I've been having a problem with the scheduled posts for some time now.

    I tried installing a plugin that supposedly would publish posts that missed the schedule, but what it ended up doing was publishing all posts that were scheduled (even in the future) at the same time.

    I also tried running the chron job myself, as I found in a post somewhere from google and it didnt work either. I also changed the timeout on the cron.php file inside wp-includes to be 10.00 seconds instead of 0.01, still nothing. Today I disabled WordPress Database Backup plugin. Going to see if that could solve the problem.

    I've been having this problem ever since we changed our domain name to be https. I don't know if that could have anything to do with it, but it might. Could someone point me in the right direction? My client is tired of having posts miss schedule and having to log in during the weekends to post the posts that had been scheduled for the weekend.

    Thanks for your time.

    The blog is installed in https://www.businessfinancestore.com/

  4. christiang69
    Member
    Posted 1 year ago #

    Anybody? I'd love some help please.

  5. Chris Barrett
    Member
    Posted 1 year ago #

    Hi @Christiang69,

    Probably not the answer you want to hear, but I:

    1) Switching hosting providers (went to HostMonster/BlueHost). I don't think it was a host issue, as the old host had no problem with the Scheduling of posts, but I had other issues and was thinking about switching anyways.

    2) Exported my site and imported it into a clean database and rebuilt it (thank goodness my site was small...)

    Cheers!

    Chris

  6. christiang69
    Member
    Posted 1 year ago #

    Thanks for your response Chris, unfortunately I can't change my server :-S I recently changed to this server and it was a partial nightmare, cause I have many many sites and the wordpress I'm referring to, alone, has 1,000 posts already. So I'm going to need a solution for this server :P but once again, thanks for letting me know.

  7. bhpress
    Member
    Posted 1 year ago #

    Just to verify, you setup a cron job to call the wp-cron.php file, or are you letting wordpress try and create the cron themselves? At least in my hosting we don't have access to crontab, so we have to set it up through their cron system.

  8. Chris Barrett
    Member
    Posted 1 year ago #

    In my case, I was having no problems letting WordPress create the cron itself.

    The issue came up when my option_name chron ballooned from about 805 characters to 1.6MB in size. Something (plugin, whatever) duplicated the data in that SQL field a few thousand times.

  9. christiang69
    Member
    Posted 1 year ago #

    @bhpress, I set up a cron job that called the wp-cron.php file every 15 minutes, but it didn't fix the issue :(

  10. bhpress
    Member
    Posted 1 year ago #

    What is the command that you used in the cron job? If it isn't working you can also try running that same command through ssh. If it fails in ssh you will at least get an error. Does your host give you access to ssh?

  11. christiang69
    Member
    Posted 1 year ago #

    Hi @bhpress, thanks for the help.

    The command that I used in the cron job in my server was this:
    /usr/bin/curl https://www.businessfinancestore.com/wp-cron.php

    Yes, we have access to ssh and we tried the command in ssh using putty but we didn't get any error. It just asked for the next command :-S

  12. bhpress
    Member
    Posted 1 year ago #

    That is weird. If it is working in ssh it should work in your cron job. I ran the same command on my box and it went through without an issue. The other thing you might want to try is run the command through the file path, instead of the URL. You should also be able to send the output to an email to yourself. I hope this helps. Honestly at this point it may be time to start contacting your host. Without knowing your hosting setup I am going to be grasping at straws here soon.

  13. christiang69
    Member
    Posted 1 year ago #

    Thank you for all your help bhpress and everyone here. I did what you mentioned, running the command through the file path and now sometimes the posts are going out on schedule, and sometimes they miss the schedule. So at least it's partly working :)

    Is there any information I can give you that would help you not be grasping at straws? or something I should ask my hosting provider?

    Once again, thanks a lot for all your help. You guys are teaching me a lot :)

  14. bhpress
    Member
    Posted 1 year ago #

    You may also need to check the permissions. wp-cron.php should be set to 644 permissions. How often do you have your cron set to run? You can setup your cron to run every 5 minutes, that is how it is setup on mine.

Topic Closed

This topic has been closed to new replies.

About this Topic