WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Scheduled Posts not Publishing (3.8) (18 posts)

  1. Ariane Griffiths
    Member
    Posted 8 months ago #

    Hey there.. I noticed that since I have updated to 3.8 my scheduled posts do not actually publish when the scheduled time comes round - I am always left with a message that says missed schedule..

    Anything I can be doing to fix this? I looked at the forum and saw a few cron ideas, but they all are fine..

    Your help is super appreciated!
    Thanks,
    Ariane

  2. Chadwickhugh
    Member
    Posted 8 months ago #

    I too am having the same issue. Also running 3.8. Woke up this morning to find my scheduled posts had not published, with the same "Missed Schedule" message.

  3. boutiqueshops
    Member
    Posted 8 months ago #

    I'm having this problem as well. I'm not even seeing a "Missed Schedule" message. Tried deactivating WP Super Cache, no help. Same with WP Database Manager.

    I also tried changing the post back to draft and saving the post. Then trying to update to Published from Quick Edit on all posts page. Still no joy.

    :(

  4. Ariane Griffiths
    Member
    Posted 8 months ago #

    But we still have no response from help?! :(

  5. Leslie P
    Member
    Posted 7 months ago #

    Same here - "missed schedule". I also found it impossible to publish that post, had to just create a new one and copy and paste. Is there some way to convert a post from scheduled to "publish right now"? Especially since scheduling appears broken.

  6. gerhard59
    Member
    Posted 7 months ago #

    Same here, checked the cron jobs and they are all fine.
    I am looking at using "wp missed schedule fix failed future posts" but rather want the regular cron job to take care of publishing.

    @Leslie P I found that by using the quick edit option instead of edit you can publish the post.

  7. Leslie P
    Member
    Posted 7 months ago #

    Thank you @gerhard59 ! It never occurred to me to try Quick Edit.

    I have found that the WP Missed Schedule plugin works, and that's what I'm going with for now - but it's SO tiresome to have to keep using plugins for things that should just be part of the software's core functionality.

  8. gerhard59
    Member
    Posted 7 months ago #

    @Leslie P This afternoon I installed the missed schedule plugin just to make sure scheduled posts are published. Only 5 more sites to do this weekend.

  9. Bluebird Blvd.
    Member
    Posted 7 months ago #

    Same here with the missed schedule problem, Arianne Griffiths— @gerhard59, I tried "WP Missed Schedule fix failed future posts" and I could not get it to work either. Just like you, my site's cron jobs were perfectly fine. The time signatures on my stuff appear to be okay as well.

    As for the posts, I knew to publish from Quick Edit if I saw a "missed schedule" note—

    For those of you knew to WordPress who sorting out how to post a missed post, go to your posts list in your dashboard, open the post that should have posted and change the status from "scheduled" to "published." Remember, though, that the post will publish to whatever time it was supposed to publish, not the current time.

    My scheduled posts are supposed to go up before I'm awake since I have an international readership. This missed post thing is really a problem for me. I create original content and some of it is time sensitive. I'm really bummed out about this. If I find a fix, I'll be sure to check back in with y'all.

  10. jaycurrie
    Member
    Posted 7 months ago #

    Hi all,

    This may not work for everyone but I had a client whose blog running WP3.8 ran into the "missed schedule" problem.

    I tried the plug-in but it would not activate. And I tried de-activating assorted plugins and noticed that they would not deactivate. That suggested there was something amiss in the mysql database itself and, lo and behold, my client had gone over the default 100MB limit on his database. Quick trouble ticket to my pals at Servage.net and we bumped the limit to 200MB...Problem solved.

  11. Culi Amsterdam
    Member
    Posted 7 months ago #

    We had the same problem over this weekend. After the scheduled time, when pushing update it went online. After 1-2 days it is working fine again. I guess it is a 3.8.1. problem!
    Now it is working again without problems!

    However, not can't share on facebook or Google+ for some reason

  12. TomFakler
    Member
    Posted 7 months ago #

    Hello,
    Running WordPress 3.8.1 and having the same problem you all are having.

  13. jefflabonte
    Member
    Posted 6 months ago #

    Same problem here, just started this week. Got one error on Wednesday, then all five failed to post today (it's an online newspaper, so kinda need this feature!).

    And no response from developers after a month???

  14. leisegang
    Member
    Posted 6 months ago #

    Have you tried this one?

    WP Missed Schedule Fix Failed Future Posts - https://wordpress.org/plugins/wp-missed-schedule/

  15. Bluebird Blvd.
    Member
    Posted 6 months ago #

    Thank you so much for the suggestion, leisgang! As for WP Missed Schedule Fix Failed Future Posts, I did install it for a week, and I did not experience a change in missed schedule posts. I've gone ahead and deleted that plug-in, andI've just reinstalled WP Crontrol. Now I'm going to check all of my scheduled cron jobs.

  16. Bluebird Blvd.
    Member
    Posted 6 months ago #

    Okay, I've got scheduled posts up and running now. I read this four-year-old message thread v. carefully:


      Scheduled Posts Still Not Working

    Before I added the new callback function recommended by Samuel Wood in that message thread, I also cleared out any plugins that might conflict with post scheduling, did a check on my theme for same, and then combed through my wp-config file looking for any code debris left by plugins I was no longer using. (A caching plugin I tried and removed two months ago left a few things laying around in wp-config that probably should not have been there.) And finally, I reinstalled WordPress for good measure. (Some of these checks were recommended by WP.ORG Moderator Esmi in that same four-year old thread.)

    At that point, I added the callback function mentioned in the message thread above.

    I have run four staggered test posts for the last two hours, and posts now seem to be posting on time. However, my grandmother used to always say, "There's no such thing as a free lunch," and boy, was she right. Please read the warnings in the next two paragraphs.

    A NOTE OF WARNING: After a year of heavy studying, I do understand why the added define parameter works, but just barely. Much of my understanding of this fix today has to do with the person who wrote the fix, Samuel Wood. Please do not ask me for further explanation if you do not understand the link above, because I will be useless. Seek out a proper volunteer moderator and ask her/him for help.

    CAVEAT EMPTOR!: One more thing, and this is important to understand before you do anything: Wood clearly states at the end of his explanation that this method is not an absolute fix but a workaround, and this workaround may not have consistent results.

    FINAL THOUGHTS: If I find more than a casual inconsistency in posting, I will come back and mention it here or I will open a new thread where I will ask a proper moderator for assistance. In any case, I live in hope. Best of luck to you all.

    EDITED ONCE: For clarification of a very muddy sentence.

  17. Bluebird Blvd.
    Member
    Posted 5 months ago #

    Well, that was too good to be true!

    While the fix I mentioned above does work, it also adds a weird suffix to my site address for some reason. Because I don't know enough code to get myself out of the trouble I get myself into, I went ahead and removed that additional callback item from the wp-include file.

    *Sigh* Back to the drawing board, I guess. Has anybody seen my crayons?

  18. dhruvkb
    Member
    Posted 4 months ago #

    I ran the /wp-admin/upgrade.php and it started to work.

Topic Closed

This topic has been closed to new replies.

About this Topic