WordPress.org

Ready to get started?Download WordPress

Forums

Scheduled posts do not appear (38 posts)

  1. sequenceinc
    Member
    Posted 7 years ago #

    I posted a question under a similar topic, but it is marked "resolved" so I got no response. It doesn't look resolved to me. Can anyone point me to the fix that will make the scheduled posts go live when I have them timestamped? This is a problem w/ my 2.1 install.

  2. Jonathan Landrum
    Member
    Posted 7 years ago #

    I'm having the exact same problem, and no, it's not resolved. I'm following two tickets on TRAC about this:
    http://trac.wordpress.org/ticket/3565
    http://trac.wordpress.org/ticket/3742

  3. joeks
    Member
    Posted 7 years ago #

    When I am editing my website online in log in, the posts aren't appearing in the main website that my members use.

  4. Jonathan Landrum
    Member
    Posted 7 years ago #

    Actually, what this thread is about is future-dated posts that never go live.

  5. sequenceinc
    Member
    Posted 7 years ago #

    But no one has come up with a fix yet, right?

  6. Chris_K
    Member
    Posted 7 years ago #

    Not that I'm aware of from reviewing the mentioned Trac threads.

    What's odd is I future-dated one last night and it showed up fine this morning as expected, so we can't say it is categorically broken for all.

    You might want to contribute to the trac articles with your server details to help narrow it down?

  7. sequenceinc
    Member
    Posted 7 years ago #

    Are you suggesting that I might actually know my server details? *grin*

  8. Chris_K
    Member
    Posted 7 years ago #

    Lol, touche'

    If you're feeling zesty, you could build a phpinfo.php file with contents:

    <?php php_info() ?>

    Upload it to your site and hit it with a browser. That'll tell you (among other things) things about versions of apache and such.

    Or you could ask your host for the details (which is a lot easier if your host is helpful)

  9. drmike
    Member
    Posted 7 years ago #

    It's an issue on occasion with wp.com and the WPMu software as well. :(

    It's not specific to 2.1.2.

  10. Jonathan Landrum
    Member
    Posted 7 years ago #

    But it is specific to the 2.1 branch. 2.0 doesn't have this problem (as far as I can tell).

  11. sequenceinc
    Member
    Posted 7 years ago #

    Grrrr... tried the phpinfo thingy and all I got was a blank page. I'll have to have my web dude look at this next week. I hope someone comes up with something brilliant soon, because I truly depend upon future dating posts to keep things running smoothly. :)

  12. Jonathan Landrum
    Member
    Posted 7 years ago #

    Ditto. The most dificult thing about fixing this is that the vast majority of folks don't seem to have the issue, so it's almost impossible to mark as a bug in WP. There's the guy who started the TRAC thread (Trent), a couple others who have posted there, and the two of us. If there are others, I haven't seen their comments on this forum or at TRAC.

  13. cou
    Member
    Posted 7 years ago #

    I'll throw my hat into the ring. I did see someone, somewhere, had a solution with WP's cron files not having the right permissions. But I'm still stuck and it still doesn't work :(

  14. Jonathan Landrum
    Member
    Posted 7 years ago #

    Yeah, Trent mentioned that on one of those TRAC threads, but there was nothing about which specific files had the wrong permissions. wp-cron.php doesn't need any special permissions to work.

  15. cou
    Member
    Posted 7 years ago #

    And nor does includes/cron.php (to my knowledge). Maybe I should roll back to 2.11 or even earlier...

  16. Jonathan Landrum
    Member
    Posted 7 years ago #

    No! Oh, golly. Please don't do that. Roll back to the 2.0 branch if you must, but don't roll back anywhere in 2.1. It's not safe. :o)

  17. sequenceinc
    Member
    Posted 7 years ago #

    I didn't even know it was possible to roll back. Anyone want to give me a clue where to send my web guy for instructions?

  18. cou
    Member
    Posted 7 years ago #

    I meant 2.0 Jon :) Wouldn't touch 2.1ish. Is anyone any closer to fixing this? It's causing me huge problems!

  19. Jonathan Landrum
    Member
    Posted 7 years ago #

    Ha ha! Yeah, I've been thinking of 2.0.9 myself. sequenceinc, the only way to roll back and keep your stuff is if you have a backup of your 2.0 version. Moving to 2.1 changed the database irreversably. Beyond that, it's delete everything, upload 2.0.9, and start rebuilding one post at a time. :o\

  20. cou
    Member
    Posted 7 years ago #

    Any further progress with this?

  21. zerohalo
    Member
    Posted 7 years ago #

    I'm experiencing the same problem after upgrading to WP 2.1. Unfortunately I don't have the possibility of rolling back to WP 2.0. Is there any possibility of fixing this???

  22. cou
    Member
    Posted 7 years ago #

    No good news I'm afraid zerohalo. I'm still having the same issue.

  23. sirgt
    Member
    Posted 7 years ago #

    with all the responses to this post i get messed up but if the problem is that the scheduled posts aren't showing in the dashboard (Scheduled Entries: section) the solution is this...

    you have to modify your db.. go to the posts table and add to the list in posts-status field the string future and that's all... this was solved by Abasme and me after a couple of hours figuring out this issue ... I hope this helps

  24. chewblocka
    Member
    Posted 7 years ago #

    I think I have discovered another cause for this. I am having the same issue. I saw several people chalk this up to DNS...however, when I created a simple php script to try and fsockopen my own host over port 80 I see an error 111 Connection refused. Since this is on a server I managed and setup, it suddenly made me remember the firewall I configured. It is VERY common that the very first rule in a firewall is to deny any connections coming over the external card that claim to be originating from yourself. This is a common ip packet spoof used in DOS attacks and why would you be connecting to yourself over the outside network anyway...use loopback. SO, the issue here is that the fsockopen connection over port 80 to myself was being blocked by the firewall. To solve this you need to chnage this line

    $cron_url = get_option( 'siteurl' ) . '/wp-cron.php';

    to this

    $cron_url = 'http://127.0.0.1/wp-cron.php';

    You may need to add more before the wp-cron.php if your wp install is in a subfolder. This will cause the connection to be made over the loopback interface and the firewall will allow it as it should.

    I suggest (and will create a trac ticket) that the wordpress code change to do this by default, or at least give you the option.

  25. Jonathan Landrum
    Member
    Posted 7 years ago #

    chewblocka, what file is that?

  26. omniguy
    Member
    Posted 7 years ago #

    Hi everybody! I'm a new member in this support forum and the reason is because I'm having the same problem as you guys - my scheduled future posts do not appear. I'm using WordPress 2.2 and I have no solution but want to tell you how it works for me, maybe it can be a clue to someone.

    My posts seem to become published when they are supposed to, except that they don't show. But, as soon as someone viewing my site - anyone out there - hits the reload button on their browser, the post appears and the ping goes out. Really strange if you ask me.

    I've had so much problems with WordPress now that I'm seriously considering changing to another blog/publishing tool. I'd prefer to find a quick and easy solution to this problem though and not having to go through the hassle of changing. Best of luck to you all!

  27. tinhead
    Member
    Posted 6 years ago #

    Some more commentary on this issue here:

    http://wordpress.org/support/topic/103289

  28. chrisforce
    Member
    Posted 6 years ago #

    Hi, I never experienced this problem--until I upgraded to WordPress 2.3. Does this in anyway rule out that it is a server side problem (if the upgraded only affected WordPress, and not the server...)?

    To elaborate, when I make a timestamp set for the future, the post no longer published on that date, I need to reopen that post once that timestamp has passed and click "save".

    Thanks.

  29. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Hi, I never experienced this problem--until I upgraded to WordPress 2.3. Does this in anyway rule out that it is a server side problem?

    No. Actually, it pretty much confirms that it is a server problem.

    WordPress 2.3 handles things differently. For this functionality to work, the server must be capable of connecting back to itself. Most servers allow this. A few have misconfiguration problems, some have firewall issues. Nevertheless, servers that do not allow connections back like this are not WordPress 2.3 compatible and must be fixed. Talk to your host about it.

  30. chrisforce
    Member
    Posted 6 years ago #

    Thanks Otto, I'll chat with them tomorrow. I use Genevate, and they have been really WordPress savvy and friendly so far.

Topic Closed

This topic has been closed to new replies.

About this Topic