WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Scheduled database backups no longer working (35 posts)

  1. manunkind
    Member
    Posted 1 year ago #

    The latest version of W3 Total Cache also breaks any scheduled database backups within plugins such as WP-DBManager. Confirmed with multiple database backup plugins. Disabling W3 Total Cache fixes all the issues.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. kato
    Member
    Posted 1 year ago #

    Same boat: WP-DBManager breaks database cacheing in W3TC for me.

    But I did the opposite as you because working W3TC is more important than scheduled db backups. I guess I'll just have to do them manually...

  3. ptnplanet
    Member
    Posted 1 year ago #

    If you are using the file/disc object cache, this is because wp-cron does not work anymore. The wordpress cron and transient API rely on their values being saved persistently in the wordpress cache between requests. Having W3 Total Cache installed and using disc/file based object cache, these values are stored as w3 cache files and they are broken:

    http://wordpress.org/support/topic/updated-w3cache-and-now-very-slow?replies=6#post-3710678

    You can verify this by installing a cron viewing plugin like WP-Crontrol: http://wordpress.org/extend/plugins/wp-crontrol. You will notice, that the crons "next-run" values are not updated. This is because they are simply not run.

  4. kato
    Member
    Posted 1 year ago #

    Nice tip ptnplanet.
    This explains a lot. I upgraded WP3.5 core, W3TC, and WP-DBManager at the same time and couldn't isolate the problem.

  5. nhowarth
    Member
    Posted 1 year ago #

    Thanks guys - I have this problem too with WP-DBManager, but didn't realise I had it until I came across your reports.

  6. sLa NGjI's
    Member
    Posted 1 year ago #

    For my personal opinion, for this specific and others related issues, the problem is not WP-DBManager plugin, or W3 Total Cache, but a WordPress core bug regression. Add more cron, freeze WordPress to work correctly. Deleting WP-DBManager, or W3 Total Cache, save more cron core sessions, and WordPress seem to work. WP-DBManager is one of my fovorites plugin, and for me work fine. WP-DBManager author GamerZ is a WordPress guru for me. W3 Total Cache is affected to more bugs and security hole. I have 30 WordPress 3.4.2 installation, on vary host, and, for me, all work fine with WP-DBManager + W3 Total Cache. The only problems is when was upgraded to WordPress 3.5 ... WP Crontrol is a very importatnt cool plugin!

    @ptnplanet

    Your analysis is very accurate :)

  7. funkster
    Member
    Posted 1 year ago #

    Thanks for those that have posted, thankfully I came across this post without too much trouble finding it.

    So what's the fix? I don't want to disable either Plugin, that's why I have them both, because I want them both!

    In WP-DB, it's saying that the MySQL paths do not exist, is this related?

  8. sLa NGjI's
    Member
    Posted 1 year ago #

    @funkster

    it's saying that the MySQL paths do not exist, is this related?

    Paths do not exist, if database is not hosted on the same machine of hosting files ;) (godaddy for example)

  9. manunkind
    Member
    Posted 1 year ago #

    So what's the fix? I don't want to disable either Plugin, that's why I have them both, because I want them both!

    I'm just doing my database backups manually until it gets fixed. To me, it's not worth downgrading any of the software and re-introducing the (now fixed) vulnerabilities.

  10. Jun Harefa
    Member
    Posted 1 year ago #

    I've disable database cache on my w3 total cache setting.

  11. nhowarth
    Member
    Posted 1 year ago #

    "I've disable database cache on my w3 total cache setting." Thanks - I've done the same - cron jobs now OK.

  12. ph23man
    Member
    Posted 1 year ago #

    Well I'm on 3.4, not even 3.5, and W3TC has disabled all cron functions, including backups and scheduled posts.

    Thanks ptnplanet for pinpointing the issue.

  13. funkster
    Member
    Posted 1 year ago #

    Disabling functionality on a Plugin is not the solution I'm looking for. I want to retain full functionality on all Plugins.

    This is meant to be a Support forum, so where is the developer's support or are we saying it's a WordPress issue?

  14. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    @ptnplanet is right. You can set up a cron on your server to call WP Cron if you find this issue happen. This mostly happens to users with users on shared hosting that don't have a lot of WP Admin usage or comments. In those cases database caching in particular to disk specifically is not going to provide benefits and should be disabled.

  15. funkster
    Member
    Posted 1 year ago #

    Hi Frederick,
    Thanks for dropping in. I'm on a VPN, what would you advise here?

  16. funkster
    Member
    Posted 1 year ago #

    For Info,

    ENABLED - Page, Minify, Object, Browser, CDN

    DISABLED - Database, Varnish, Cloudfare

    I'm not clear on what my solution is.

  17. ph23man
    Member
    Posted 1 year ago #

    I'm running on a dedicated server and still having this issue. Just tried disabling database cache and a scheduled post still failed.

    I think the solution is just to set up a cron job to call wp cron like Frederick mentioned, maybe every 5 minutes or something. Actually is 5 minutes too much? My understanding is that WordPress calls wp-cron.php basically everytime any page is accessed so it should be okay right?

  18. manunkind
    Member
    Posted 1 year ago #

    I think I am confused now too. I know for a fact that I can go back to the previous version of W3 Total Cache and all of this will work correctly. I can't speak for everybody here, but ONLY upgrading to the latest version of W3 Total Cache is what broke my setup. This is why it's hard for me to accept that it's a bug in WordPress 3.5.

  19. ptnplanet
    Member
    Posted 1 year ago #

    I can only repeat myself. The problem came with the latest W3 Total Cache security update which breaks W3 Total Cache's file/disc based cache. This results in wp-cron not working anymore.

    Two ways to fix this:

    1. Fix it yourself. It is only one line of code to insert. I wrote about it here: http://wordpress.org/support/topic/updated-w3cache-and-now-very-slow?replies=6#post-3710678
    2. Disable W3 Total Cache's file/disc based cache or switch to a different object cache driver.
  20. manunkind
    Member
    Posted 1 year ago #

    Holy crap. ptnplanet, you have my apologies. I actually bookmarked your link when you posted it to "check it out later" and totally forgot about it. Then I just got distracted with all of today's new replies. So sorry. Yes, you have a valid fix for this and it appears to have worked.

    Thank you.

  21. darkpollo
    Member
    Posted 1 year ago #

    What is amazing is that the author read this and still after he said:

    @ptnplanet is right.

    We do not have an updated version that fix this.

    :(

    I have disabled the cache to see if this helps.

  22. SLIS
    Member
    Posted 1 year ago #

    I use Backwpup and have the same issue. DIsabling database/object cache doesn't seem to help, and backups just hang in limbo when uploading to dropbox. For now I just deactivate W3 while doing backups and reactivate when they're complete. Hope this gets fixed soon.

  23. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Can anyone let me know if issues still persist in the last version?

  24. Kalpit
    Member
    Posted 1 year ago #

    @Frederick Yes! It's still there.
    I'm using BackWPup with W3TC, and crop jobs aren't working. Any fix?

  25. ccolotti
    Member
    Posted 1 year ago #

    I have just found out cron jobs are not working now as of yesterday when I went to the latest version and I am NOT using disk caching I am using APC.

  26. ccolotti
    Member
    Posted 1 year ago #

    This was working up until I updated to the latest version of the Cache plugin. I had not had any missed posts or anything so now I am not sure what in the new version broke the previously working scheduled posts.

  27. David Anderson
    Member
    Posted 1 year ago #

    Same problem with the UpdraftPlus plugin, which I maintain - we've had a few user reports traced back to W3 Total Cache. Cron was working, but when the scheduled task looked for its transients, set 5 minutes earlier with an expiry time of 9 hours, they weren't there. Disabling W3 Total Cache fixed the problem in each case.

  28. ccolotti
    Member
    Posted 1 year ago #

    So can ANYBODY determine what in W3TotalCache is preventing CRON from working? Seriously, they are not speaking up and it's frustrating. Can you as another plugin author debug the settings and see if there is tickbox or tweak someplace that gets CRON working again since you also rely on it?

    I am sure once we find it ALL things broken with CRON like scheduled posts and backups wil again start working.

    The W3TtotalCache people need to start speaking up and helping here! Frederick please HELP this is not an isolated issue with your plugin!

  29. Willie Jackson
    Member
    Posted 1 year ago #

    Please get in touch with us directly about the issue if you're still having problems: http://www.w3-edge.com/contact/

    We are unable to monitor all the forum threads about W3TC and can provide the best support when there's an email to track and a site to test on. Sorry for the trouble.

  30. ccolotti
    Member
    Posted 1 year ago #

    SO I reverted back to 0.9.2.5 and got things working again. However, something I discovered is you need to not only DISABLE object cache but you need to REMOVE the object-cache.php file from /wp-content for CRON jobs to start working again.

    I am still working on the new version but nothing seems to work. I have filed a bug that it must be de-activated for it to work. I also have a manual CRON job running every 5 mins now and that works when the new one is not activated. I will need to stay on 0.9.2.5 until they work out this bug.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic