WordPress.org

Ready to get started?Download WordPress

Forums

Online Backup for WordPress
[resolved] Scheduled Backup not respecting custom filesystem excludes (5 posts)

  1. Herbert
    Member
    Posted 1 year ago #

    Recently upgrade first to 3.0, now to 3.0.1. As there is now the possibility to schedule local, encrypted backups, I enabled this feature yesterday. This morning I was slightly shocked. There were 8 new backups created and my previous manual backup was gone. I had configured maximum 300MB usage and minimum of 8 backups to retain...

    It seems like something is going wrong with the scheduling if the backup takes slightly longer... What is even worse, none of the 8 backup files can be decrypted! An error is shown about file integrity when trying to decrypt these files, the files are about 314MB in size. To test decryption once more, I created a manual backup (only 21MB now instead of 314MB), which decrypts fine. The scheduled backup however is defunct.

    Which brings me to the issue in the "topic title": I have Next-Gen Gallery installed and a number of pictures in the patch wp-content/gallery and this is on the exclude list under general settings.
    This always worked for manual backups in the past, but the scheduled backup simply ignores it and also backups the gallery directory.
    I can reproduce this on the test/dev site also.

    The test/dev site only has small galleries, so that the scheduled backup seems to work correctly there, it finishes within about 50 seconds.
    The production site is bigger and the backup takes about 40 seconds with manual backup (excluding gallery), but it takes longer for scheduled backups, as there the gallery directory is also backed up.

    ...

    For now I had to disable scheduled backup. Can you please check that? Thanks.

    http://wordpress.org/extend/plugins/wponlinebackup/

  2. fp2x
    Member
    Posted 1 year ago #

    Hi,

    Scheduled backups used to work fine until I migrate to 3.0.1.

    Now, if I perform a manual backup, everything is fine. The excluded folders are taked out from the backup.

    However, the scheduled backups constantly ignores my excluded folders. Even if I click on the checkbox 'Exclude wp-content/plugins' or if I add 'wp-content/plugins' explicitly, it doesn't work either.

    Can you have a look please ?

  3. Online Backup
    Member
    Plugin Author

    Posted 12 months ago #

    Hi Herbert / fp2x,

    There are two issues you are having:
    * File system excludes not getting matched
    * Decryption not working for big backup files (around above 50MB for example)

    Both of these will be fixed in 3.0.2. The first seems to only happen on specific environments. The second was common.

    3.0.2 will be released shortly. Today or tomorrow. If you have issues still let us know. Please provide the information from the Help & Support tab in the plugin too if you do so we can check what type of server environment we're working on.

    Thanks and apologies for the issues you've encountered.

    Jason

  4. Herbert
    Member
    Posted 11 months ago #

    The scheduled backup tonight worked correctly, excluded the specified extra paths.

    Thanks!

  5. Online Backup
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks for the update Herbert!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic