WordPress.org

Ready to get started?Download WordPress

Forums

Schedule Posts Not Working in 2.5 (100 posts)

  1. mdesiderio
    Member
    Posted 5 years ago #

    I used Kim's soution (http://www.kimwoodbridge.com/scheduled-posts-in-wordpress-dont-work-a-possible-solution-for-iis/) + set my blog's time at UTC and it works !!!!

    Check the link or do what she suggests:
    In your WordPress directory, edit /includes/cron.php. At line 84 and 85 replace

    $cron_url = get_option( 'siteurl' ) . '/wp-cron.php';
    $parts = parse_url( $cron_url );

    with

    $cron_url = 'http://127.0.0.1/wp-cron.php';
    $parts = parse_url( $cron_url );

    Thank you Kim!!!

    The problem is definitely a matter of IP (I think my host: Yahoo! does not have a fix IP for the websites => when I ping http://www.transport-expertise.org, I always get a different IP address...)

  2. kwbridge
    Member
    Posted 5 years ago #

    Hi - I'm glad it worked for you.

    You use Yahoo! for hosting? Someone else I knew was using Yahoo! and had the same problem but told me my fix didn't work. Perhaps it wasn't done correctly. At any rate I'm glad this fix works for some people.

  3. mdesiderio
    Member
    Posted 5 years ago #

    Yes, I have a Yahoo! Small Biz hosting. And it works perfectly => my newsletter plugin now works well (I have been sending 10 emails per hour to my subscribers list since yesterday.

    And posts scheduling now works perfectly.

    Simply GREAT!
    thx

  4. cipote
    Member
    Posted 5 years ago #

    It's not working of me even after updating to 2.7.
    I'm also using Yahoo Small business as my hosting.

    $cron_url = get_option( 'siteurl' ) . '/wp-cron.php';
    $parts = parse_url( $cron_url );

    I don't see these lines in my wp-cron.php file...

  5. Shirley
    Member
    Posted 5 years ago #

    There's an "Idea" section within WordPress.org where I added the idea of bringing back schedule post.

    http://wordpress.org/extend/ideas/topic.php?id=2218

    This beneficial setting has been missing for a long time, and by the number of posts in this thread, many of us would appreciate its return.

    If it's not on the menu for version 2.8, the "Publish Status" section to the right of the "Write Post" page can be eliminated.

  6. binbin
    Member
    Posted 5 years ago #

    I have the same problem with wordpress 2.7
    How I can fix it ?

  7. stevejohnson
    Member
    Posted 5 years ago #

    For those of you having trouble with this, it could very well be security settings at your hosting company. HostGator, for instance, just upgraded their servers; in the process of upgrading Apache, they also installed mod_security. While this can be a good thing, it broke a lot of things on my blogs, including scheduled posting and also the 'Press This' function.

    Thankfully, HostGator was fully supportive and put my domains on a 'whitelist' to bypass some of the security settings. Voila, everything now works.

    Don't be too fast to criticize WordPress - while a few things sometimes don't work as planned, in this age of heightened server security there are a few script functions that get caught in the lurch.

    P.S. For those of you on Yahoo Business Hosting, MOVE. Yahoo is one of the least friendly hosting providers I've ever seen.

  8. perfectlyclear
    Member
    Posted 5 years ago #

    There are hundreds of threads on the forum with people having issues with Scheduled posts not working after 2.5 and above. Unfortunately if your host is not willing to modify their firewall just for you (which most will not) then you have 2 choices, go back to an earlier version of wordpress, or wait... It sucks I know but it's as simple as that; and as far as I've seen there has been nothing posted that will rectify the problem.

  9. Shirley
    Member
    Posted 5 years ago #

    I've achieved success with this long-term problem.

    I upgraded my SoloBusinessMarketing.com blog to version 2.7 through the WordPress Automatic Upgrade plugin, wrote an article, set it to publish the next morning, and it worked.

    I don't know if it was my host or the plugin; I'm just pleased to announce this in hopes that others will also find a solution.

  10. kwbridge
    Member
    Posted 5 years ago #

    cipote - the cron.php file is different in 2.7. Recently, I used one from an earlier version of WordPress, made the edits, and used that file instead for someone having the problem after upgrading. She can now schedule posts again. I have not determined, however, if using an older version of cron.php will cause other problems.

Topic Closed

This topic has been closed to new replies.

About this Topic