WordPress.org

Ready to get started?Download WordPress

Forums

Schedule Posts Not Working in 2.5 (100 posts)

  1. talia
    Member
    Posted 5 years ago #

    ok will give it a go tonight and cross my fingers!

  2. yokyek
    Member
    Posted 5 years ago #

    Try script from this blog, it help fixing cron queue

    http://smilesquare.com/wordpress-cron-fix/

  3. talia
    Member
    Posted 5 years ago #

    yokyek that comes up as an invalid link

    has anyone resolved this?

    i went to my cron job manager after putting the cron.php file into the wordpress installation. However I don't know what command to type into the cron job manager. Can someone please tell me what to type?

    Thanks

  4. clivemcg56
    Member
    Posted 5 years ago #

    This is just SO bad that, while I appreciate those that are trying to find a fix, I question Open Source! Is this the thread to monitor for a possible fix?

  5. talia
    Member
    Posted 5 years ago #

    I tried running that job using cron but I'm not sure I did it right. Now future dated posts post immediately instead of waiting until the scheduled time

    Frustrating!

  6. talia
    Member
    Posted 5 years ago #

    Does anyone have a solution to this?

    I must have the wrong cron job file because it is not working. Can someone please post the correct full code for the wp-cron.php file

    thanks!

  7. hadriel
    Member
    Posted 5 years ago #

    I scheduled 4000 posts in WordPress 2.6.1 and they stopped publishing.
    Great hah!

    I found out wp-cron.php is running out of memory and after allocating more it now works again :)

  8. LJatRAR
    Member
    Posted 5 years ago #

    Schedule posts worked for me last week. This week? Nope.

    Over the weekend I installed WP Super Cache and that is the only thing different since last week. I've deactivated it, but still no scheduled posts.

    Anyone else using WPSC?

  9. danielpereira
    Member
    Posted 5 years ago #

    Well, I have found my solution to the posting problem, I doubt this is going to fix it for everyone (it's a very simple fix due to my ignorance) but I wanted to share it with everyone because I spent 2 days stressing and 5 hours of research trying to figure out why my scheduled posts weren't posting, then I figured out what my problem was.

    Here it is:

    http://www.thefreetrafficformula.com/blog/?p=211

    Daniel Pereira

    P.S. Dont' Laugh! And please comment and let me know if this is what fixes things for you.

  10. soundtrackgeek
    Member
    Posted 5 years ago #

    Any solution to this?

    I have some additional information. I was using Bluehost and the scheduled posting worked fine. On the same server I have a lot of different domains and blogs. I recently moved to Hostgator and my main blog stopped schedule post. If I set a post to schedule 5 minutes from now it says 5 mins from now in WP-Admin panel as it should. Of course it doesnt get posted on time and if its 2 minutes past posting time it says 2 mins from now, like it is all backwards.

    Scheduled posting works fine on all my addon-domains on the same server and on the same host.

    No WordPress installation of mine has wp-cron.php in /includes but on the root and it works fine on all my blogs except my main one.

    I have also compared wp-cron.php (which has permission 644) in my main blog vs. the others, and they are identical.

    The only difference is that I am running 2.62 on my main blog and 2.61 on my other blogs. Will try to update one of my blogs and see if stops scheduling as well.

  11. soundtrackgeek
    Member
    Posted 5 years ago #

    No difference. I am stumped.

  12. talia
    Member
    Posted 5 years ago #

    I am on bluehost and it isn't working properly for me but maybe my wp-cron.php file has an error message in it. or the cron job isn't set up correctly

    does anyone have a working wp-cron.php file that I can install to see if that fixes it?

  13. mdesiderio
    Member
    Posted 5 years ago #

    I encounter the same issue.

    I run three WP on my site. Version is 2.6.3
    PHP Version 4.3.11
    System FreeBSD hostingprod.com 4.11-YAHOO-20080312 FreeBSD 4.11-YAHOO-20080312 #0: i386
    Host: Yahoo! Smallbusiness / domain name transport-expertise.org

    Scheduling does not work: I run a version on the www. part of my site with WP-Mailing-List plugin (and I cannot use the scheduled sendings of the plugin either). I also run two other versions of WP (2.6.3) on the fr. and en. parts of my website, and the posts schedule does not work (when posting time passes, it appears "xx mins/hours ago" and post is not published.

    Is there a real way to fix it? I check all links provided in this thread and nothing looks like being do-able for my problem...

    Developers, will you please do something in 2.7.X ???

  14. stanvy
    Member
    Posted 5 years ago #

    hadriel, how do you increase memory of wp-cron.php?

    where to change that?

  15. deltaf
    Member
    Posted 5 years ago #

    Guys, you are ALL confused.

    This is the solution.

    quote:
    "...you still needed to click on the “publish” button in order to complete the scheduling process for your blog posts."

    http://www.thefreetrafficformula.com/blog/?p=211

    I hope it helps everyone. :-)

  16. daveatkins
    Member
    Posted 5 years ago #

    Does WordPress monitor this forum? Any word on when they will fix this bug? I read the article above about the publish button, but it does not work. Maybe it does technically, I don't know, but it does not work from a usability standpoint. I have users emailing me to please publish their posts for them. The status of the post says scheduled, regardless of whether you click save or publish, so it is impossible to tell if a post will actually start showing up on time.

  17. daveatkins
    Member
    Posted 5 years ago #

    Is this problem fixed in 2.6.3? I am running 2.5.1.

    There is no "Publish" button I can find after the initial clicking of the Publish button. Typical workflow will be for user to create a new post, save it, edit it, etc. Set the publish date. Maybe publish it; maybe save again. At some point they will click the publish button and the post will appear as "scheduled" But it will never show.

    I am surprised by the lack of response here...which leads me to think maybe I am missing something or that my configuration is wrong somehow. This is a fundamental core feature of WordPress that, when broken like this, makes blogging ridiculously complicated. So it can't possibly be happening for millions of other users. Is it possible the cron job or whatever is failing? Where would that be logged?

  18. ocifant
    Member
    Posted 5 years ago #

    This was all working for me until I applied a WP upgrade (2.5.x I think). Since then, subsequent updates have been applied and the problem still occurs for me across 3 different blog sites that I admin.

    Some people are having no problem at all, so I think it's going to be a tricky one for WP folk to find and fix. In all probability, it's going to be a combination of factors which causes the problem to manifest.

    I know next to nothing about WP coding or the machinations of CRON services, but I'm willing to bet that an obscure configuration of things is screwing this for those of us affected, and that once affected the problem is solid (whatever causes it isn't reset by subsequent upgrades).

    I've all but stopped blogging because of this problem. There have been various 'solutions' put forward here, but none which work on a consistent basis for everyone. I'm not holding my breath. It's a shame, but this really is a blocker for me using WP.

    If I can provide any information about this problem to WP, I will if asked, but I'm not techy at all so questions will need to be put in the simplest of terms...

  19. deltaf
    Member
    Posted 5 years ago #

    I am currently using WordPress version 2.6.3 and the schedule post is working perfectly.

    The problem seems to be with later versions. I did not have to worry about coding or cron issues.

    I just created a post, set it to a certain date and finally, clicked the "Publish" button. The post status turned into scheduled. When the date and time arrived, it posted automatically.

    The best recommendation to solve this problem is to upgrade to version 2.6.3

    You can use the automatic upgrade plugin. Remember to back up all of your data.

    If that does not solve the problem, then it might be coming from your web host's server.

    I am currently using HostGator and up to now, I have not had any issues with their service or WordPress.

  20. mdesiderio
    Member
    Posted 5 years ago #

    I am currently using WordPress version 2.6.3 and the schedule post is NOT working properly. I also use the WP-Mailing-List Plugin, which also schedules tasks, probably using the same procedure as post scheduling - I am not a developer and do not actually know if that's really how the plugin works... but I suppose yes (if it help developers finding the problem)... I can provide anyone with the plugins file for testing purpose if needed...

    All scheduling tasks do not work for me => i.e.:

    - Post scheduling: What I do: I set date/time, write my post, and click PUBLISH => the post appears as "scheduled" in the management list, and once date/time is past... it is still scheduled but "XX minutes/hours AGO"!!
    ==> my solution: edit the post, scroll the "status" menu on the right, select "published" ==> post appears on the website with the date/time I set up previously... strange, huh?

    - Mass mailing using WP-Mailing-List Plugin: I schedule a task which generally is "10 emails every 60 minutes" (not to overload my server's ports, limited to 100 openings at a time) and to have 240 emails sent per day (a newsletter sent to over 1,400 people, it takes a week, I know...) ==> once the first sending is supposed to be sent... simply nothing gets out of the queue list... and something like this appears:
    Current Date & Time 2008-11-14 09:57:27
    Next schedule event 2008-11-13 07:20:11 => more than 2 hours before, and nothing neither happens, nor happened.

    For the records, I tried a couple suggestion: the "click Publish" is not a solution (if it appears in your management list as scheduled, it is because you clicked Publish/if you clicked "Save", it will appear in Draft, even a "scheduled draft") => this is definitely not hte solution.
    I also tried a couple cron.php and wp-cron.php files that can be found on other feeds about this issue => did not work for me either.

    A solution PLEASE!!! Thanks =)

    For development purpose, I rewrite my host servers characteristics:
    I run three WP on my site. Version is 2.6.3 > PHP Version 4.3.11
    System FreeBSD hostingprod.com 4.11-YAHOO-20080312 FreeBSD 4.11-YAHOO-20080312 #0: i386
    Host: Yahoo! Smallbusiness / domain name transport-expertise.org

  21. daveatkins
    Member
    Posted 5 years ago #

    I have solved this problem. Please, WordPress, jump in here and correct me if I am wrong but I believe I understand this now...

    The scheduled posts are caused to be published by something called wp-cron, a feature in wordpress that emulated the scheduled tasks or cron functionality of the operating system. Because wordpress is essentially a php script, not a running application, it cannot do anything that is not triggered by a request to load a page. So WordPress built in something that checks on every page load whether there are tasks that ought to be done or not.

    In order to execute the wp-cron, as a page is loading, it must peform an asynchronous request to the server to load the wp-cron script(s). It determines the request based on the General Settings configuration of "WordPress address (URL)" to construct an http request to that site. So, I assume somewhere in the wordpress code there is a "wget $address/cronscript.php" or something like that.

    It is possible your hosting server cannot access itself in that manner. For example, our servers are running multiple websites and are behind a firewall that maps an external ip address to the server. If you are sitting on a server at 10.10.10.25 that has a public address of 84.123.81.25, for example, when you try to get content from 84.x.x.x, it may not allow this because it requries going out and coming back through the router. If you are not running internal DNS then when you look up http://www.yoursite.com, you will get the external address. So the scripts in wordpress will fail to ever connect or load.

    My solution was to modify the /etc/hosts file on the local server to define http://www.mysite.com as 10.10.10.25.

    Now this is a bit technical, I know, but if you manage your own server, you can check this situation for yourself by trying to web browse to your site from the machine your site is running on. If you can do that, then this is not your problem.

    If you are going through a hosting provider, maybe you can show them what I've described here and it will make sense to them. I happened upon the solution after noticing snarky comments from a WordPress person about how your hosting provider might not have DNS configured "correctly" and that made me think "why would wordpress need to access itself?"

    If you are managing your own servers, the consequence of all this is that you need to ensure a local http client can access the "hostname" specified in "WordPress address (URL)" You need that address to resolve (DNS) and you need the ip address it resolves to to be routable to the local host. So maybe if you don't want to mess with the hosts file, you can tweak your router/firewall? If you have a loadbalanced server array, then you need to realize that wordpress is going to be doing this. There might be more security issues that peopel have in place locally--that might prevent http access to the local server.

    If you have command line access to your server, use wget to test whether you can load the hostname.

    I hope this helps everyone. It ended months of annoyance for me!

  22. TheVirtualPreacher
    Member
    Posted 5 years ago #

    Hi,

    I had the same problem, and this is how I solved it.

    http://howtogeeksl.com/archives/326

    Please be kind enough to leave a comment if you find this useful.

  23. cipote
    Member
    Posted 5 years ago #

    This test 'scheduled' blog works when I use the iPhone app to view the blog but it does not work when I use the computer browser. With the computer browser the post does not show.
    I have WordPress 2.6.3

  24. jojama
    Member
    Posted 5 years ago #

    Try script from this blog, it help fixing cron queue

    http://smilesquare.com/wordpress-cron-fix/

    Thank you, I have about 1500 scheduled posts and the script work for me.

  25. mgoldsworthy
    Member
    Posted 5 years ago #

    finally had my host look into it. for me, it was simply that wp-cron.php had wrong permissions. they set it to 644, and now it works great.

    months of frustration for a very simple fix.

  26. mdesiderio
    Member
    Posted 5 years ago #

    I would love to understand exactly how the "cron fix script" works:
    1- where to upload it?
    2- what to do next?

    thank you in advance.
    matt

  27. mdesiderio
    Member
    Posted 5 years ago #

    I just upgraded to 2.6.5, and this does not fix the problem...
    Change CHMOD to 644, and this does not fix the problem...
    I contacted Yahoo!, and the average response time is 24 hours...

    See you tomorrow!
    Matt

    For development purpose, I rewrite my host servers characteristics:
    I run three WP on my site. Version is 2.6.3 > PHP Version 4.3.11
    System FreeBSD hostingprod.com 4.11-YAHOO-20080312 FreeBSD 4.11-YAHOO-20080312 #0: i386
    Host: Yahoo! Smallbusiness / domain name transport-expertise.org

  28. kwbridge
    Member
    Posted 5 years ago #

    I'm not sure this will help or not but this corrected the problem for two people who were hosted on IIS servers.

    http://www.kimwoodbridge.com/scheduled-posts-in-wordpress-dont-work-a-possible-solution-for-iis/

  29. perfectlyclear
    Member
    Posted 5 years ago #

    Tried every hack mentioned in this post on all versiosn of wordpress from 2.6.3 to 2.7 RC1 and none of them work for me :(

  30. motoyen
    Member
    Posted 5 years ago #

    I'm running 2.6.5 and have the same problem.

    Is this a wordpress problem or a hosting problem?

Topic Closed

This topic has been closed to new replies.

About this Topic