WordPress.org

Ready to get started?Download WordPress

Forums

"Schedule Missed" Issue (13 posts)

  1. tamia
    Member
    Posted 4 years ago #

    I've recently upgraded from 2.5 to 2.8, and like many others, my scheduled posts no longer are published. NO ONE seems to have an answer to this very common problem, at least I've found no solution. I've tried the advice of many posters on WP forums as well as those found on the web elsewhere.

    However, I might have a clue which might help. Background: I had my website (www.tamiasoutside.com) hosted with Laughing Squid when I upgraded to 2.8. Scheduling posts worked just fine for a week or more after that upgrade. Then I signed up for Squid's newish "cloud" hosting, which required I move my site to a new server (and subsequent DNS change). Suddenly scheduling posts doesn't work. I get the dreaded "Missed Schedule" alert in the Dashboard display. This suggests to me that the problem is based with the server (I'll be on to Squid on Monday when they open business).

    Perhaps this will help people who are far better skilled than I to find an answer to this vexing problem which is causing a lot of us WP users serious inconvenience.

  2. Marlimant
    Member
    Posted 4 years ago #

    I have solved to the problem of missed scheduled:

    - First I recognized that wordpress 2,8 is much more slow, is a fact.
    - Then I stopped looking for an error of programming. I started to find an excessive delay.
    - Then, reading, I discovered that schedule post was not a problem of WordPress 2,8 it is a symptom of a slow system.
    - Finally I found it the solution here: http://lists.automattic.com/pipermail/wp-trac/2009-January/038071.html and consists of modifying the timeout in wp-includes/cron.php.
    Approximately in the line number 205 I changed
    wp_remote_post ($cron_url, Array (' timeout' => 0.01, ' blocking' => false));

    To 20 seconds:

    wp_remote_post ($cron_url, Array (' timeout' => 20, ' blocking' => false));

    Lamentably I have not get to scheduled post work nex to Hyper Cache (they only works together in WP 2,6) reason why you must to disconnect that plugin to see working scheduled post.
    It's work for me. I hope help you.

  3. wayangtimes
    Member
    Posted 4 years ago #

    Thanks Marlimant! It works for my site at http://www.wayangtimes.com/ :) Thanks alot.

    Basically for those using cPanel, you will have to log into your cPanel, find the file manager, access /public_html/wp-includes/cron.php, and than edit the timeout details as suggested by Marlimant.

    Works like a wonder immediately!

  4. Fernandot
    Member
    Posted 4 years ago #

    I had the same problem time ago and the solution I found was this one:

    Published at MT support forums (here)

    I've made a lot of investigation in this problem:

    - In WP you can schedule your posts for the future
    - In some cases, when time to publish the scheduled posts come, suddenly, the posts don't publish and time counter begin tu count to the future (you can figure out this as you see how your posts its several minutes to publish in your dashboard and never get published)
    - It seeems to be something related with wp-cron.php file and server configuration

    THE SOLUTION

    1. Type the following command vía SSH
    wget http://yourdomain.com/wp-cron.php
    If everything would be fine you'll see and "OK". If you're in trouble you'll see and ugly 404 error message in your terminal window. Then, follow these steps …
    2. Open your etc/hosts file
    3. See if the DNS where it points isn't the DNS address of your domain (example: your domain DNS is 75.38.40.200 and hosts file points to 125.0.0.3)
    4. Change the false DNS in the etc/hosts file to your domain real DNS
    5. Check again if your wp-cron.php file is working fine typing as above …
    wget http://yourdomain.com/wp-cron.php
    If you get an "OK" you're done it!

    This have worked for me and I'd want to share it :)

  5. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

  6. obus3000
    Member
    Posted 4 years ago #

    Plugin to solve this issue:

    http://arielbustillos.com/missed-schedule/

  7. mixtlupus
    Member
    Posted 4 years ago #

    Same happened to me but it was my own fault, I had some hacking attempts on my site and blocked an IP that loaded http://yourdomain.com/wp-cron.php

    After which no scheduled posts worked, so all I needed to do was unblock the IP and it worked fine, It turned out it was the IP of my webserver, lol

  8. d0k
    Member
    Posted 4 years ago #

    wordpress mu 2.9.1 seems bugged about scheduled post, btw Marlimant solutions works.

  9. s0fa
    Member
    Posted 4 years ago #

    Marliamant solution works, just fixed a client's blog entry that wasn't posting as scheduled. No plugin needed!

  10. topnaturalremedies.com
    Member
    Posted 4 years ago #

    I have upgraded to WP 2.9.2 and all of a sudden starting getting "Missed Schedule" posts. The software also logs out constantly which is frustrating. I have made all the suggested fixes to it with the cron.php changes, the Scheduled M.I.A.'s plugin activated and nothing is having any effect.

    Posts are still missing schedule. Is there anything else I can do or do I just have to sit tight until WordPress puts put a fix? I was wondering if there is a way I could go back to "last known good configuration" for WordPress?

  11. charlotte mertz
    Member
    Posted 3 years ago #

    After setting the prescheduling time and date, instead of hitting the OK button, just hit the big blue Publish/Schedule/Update button underneath (It changes names, depending on what else you've just done, whether you've "saved draft," hit "OK," or edited a previously saved or scheduled draft). The blue button seems to work as a joint Ok/Save-Draft/Publish-as-Scheduled order. But apparently it won't actually post unless you press it, even if it says it's prescheduled.

  12. danmondy
    Member
    Posted 3 years ago #

    Marlimants solution is not working for me. Any other ideas? I am using 2.9.2 I have tried disabling all my plugins. It still misses posts.

  13. cailen
    Member
    Posted 3 years ago #

    Fernandot's solution solved my problem.

    My issue was definitely caused by a recent move from a shared hosting service (mediatemple gs) to a self-managed vps (mediatemple dv).

    Thanks for posting this.

Topic Closed

This topic has been closed to new replies.

About this Topic