WordPress.org

Ready to get started?Download WordPress

Forums

Sucuri Security - Auditing, Malware Scanner and Hardening
Scanner shows a blank page (11 posts)

  1. Gtantra
    Member
    Posted 10 months ago #

    Hi my site is running on WP 3.4.1 and I installed Sucuri .
    When I clicked on Sucuri scanner it just shows a blank page.

    http://wordpress.org/plugins/sucuri-scanner/

  2. levseltzer
    Member
    Posted 10 months ago #

    I have the same problem. The scanner page is blank.

  3. Daniel Cid
    Member
    Plugin Author

    Posted 10 months ago #

    Can you try again? We just updated the plugin and it should work now.

    thanks,

  4. levseltzer
    Member
    Posted 10 months ago #

    it works now. Thank you.

  5. HeleneFi
    Member
    Posted 2 months ago #

    Hi I just installed the plugin after ugrading to WP 3.0.1, and I am experiencing the same thing. As soon as I scan, the page becomes blank, it spins for a while and then stops still on a blank page.

  6. Terence
    Member
    Posted 2 months ago #

    @HeleneFi ~ are you really running a WordPress website that old and expecting to be able to keep it safe?

  7. Yorman
    Member
    Plugin Author

    Posted 1 month ago #

    The blank page could be a remaining of an old bug, that is probably fixed in the latest version of the code, even so (and as Terence is mentioning) using this plugin in an old WordPress installation is not the best idea, there's even a hardening option where the site's version is compared with the previous stable version 3.7 indicating that (in some way) the plugin is not compatible with older WordPress sites.

    I suppose some people prefer to keep its site compatible with custom modifications preventing clean upgrades of the core files, but if that's not the reason to upgrade, then I recommend to download the latest stable version and keep the site updated.

    Read Why keep WordPress updated?.

  8. cajos1968
    Member
    Posted 1 month ago #

    I have this issue currently. Blank page. I installed 1.6.0 and that is running fine. PHP, WordPress etc. all up to date.

    Sucuri Plugin version 1.6.0
    Sucuri Plugin Last-time scan N/A
    Operating System FreeBSD (64 Bit)
    Server Apache/2.2.24
    Memory usage 14.89 MB
    MYSQL Version 5.5.32
    SQL Mode Not set
    PHP Version 5.4.16
    PHP Safe Mode N/A
    PHP Allow URL fopen 1
    PHP Memory Limit 256M
    PHP Max Upload Size 32M
    PHP Max Post Size 32M
    PHP Max Script Execute Time 60
    PHP Max Input Time 60

  9. jsimone
    Member
    Posted 3 weeks ago #

    Same problem for me. Running latest WordPress and Sucuri plugin. But I have some known infections. I guess injected code may be causing the issue?

  10. Yorman
    Member
    Plugin Author

    Posted 3 weeks ago #

    I'm not able to reproduce this bug, I already tried many times with multiple versions of WordPress, so I will need help from one of you. Can someone activate the Developer Debugging in your configuration file, and tell me what you see after an update of this plugin in the next version? Thanks in advance.

  11. Daniel Cid
    Member
    Plugin Author

    Posted 3 weeks ago #

    jsimone: If you have known infections inside your site, it may cause issues with our plugin (or any other you have).

    That's always the issue with security plugins. If your site is hacked and compromised already, the plugin may not work as it should (some times you even lose access to wp-admin).

    On these cases, I would recommend scanning your site remotely: http://sitecheck.sucuri.net

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.