WordPress.org

Ready to get started?Download WordPress

Forums

Scandinavian letters (7 posts)

  1. ludvig87
    Member
    Posted 9 years ago #

    Me and another friend both have the same friend. If we use danish scandinavian letters, the 3 that only scandinavia use, in our blogs, then they show up in all different kind of ways but just not the right letters.
    This happens to the blogs as well. In the admin area and the e-mail they show up with funny signs, but when you click on the comment box and read them there they show up as they should...
    Anyone who say how we can fix this?
    Thanks in advance.

  2. moshu
    Member
    Posted 9 years ago #

    It is always encoding problem. Did you change the default encoding (utf-8)?
    Any link?

  3. serendipity
    Member
    Posted 9 years ago #

    It's highly recommended to leave the encoding at utf-8. This refers to the option in your admin screen, and of course the encoding declaration in the head section of your template. (If you leave it unchanged from the default, it will use the encoding you defined in the options, but you might have changed it by hand.)
    Another source of error is cutting and pasting post content into the edit window that you have actually typed and saved in a different encoding.
    Yet another comes from importing posts from a blogging platform that uses a different encoding.
    To sort out your particular problem, we would, indeed, need the blog's url.

  4. moshu
    Member
    Posted 9 years ago #

    On your index page you have 2 (two) DOCTYPE declarations - which means you copied or called the WP index file into another file! The first one is iso-8859-1 (=Western European) but when you type in WP admin panel's text area it encodes the text - correctly - in utf-8. Characters encoded in utf doesn't display well on a page with iso-8859-1 encoding. Clean up the mess on your index file and everything will be OK!

  5. serendipity
    Member
    Posted 9 years ago #

    First, take this out of the template: <?xml version="1.0" encoding="iso-8859-1"?>. Apart from the wrong encoding, it throws Internet Explorer into "quirks mode".
    Second, you've taken out a whole lot out of the <head> section of your original template files (the ones that came with WP). There are good reasons why the stylesheet, for example, is by default included using @import url().
    At the very least, you ought to leave

    <meta http-equiv="Content-Type" content="text/html; charset=<?php bloginfo('charset'); ?>" />
    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats -->

    This ensures that your blog appears with the same encoding you set in the admin interface options (utf-8, presumably).
    The validator, btw, isn't particularly happy with your site either.
    Last, you really should leave a link to WP somewhere inconspicuous. When you're using free software, this is a gesture of politeness and recognition.

  6. ludvig87
    Member
    Posted 9 years ago #

    I use skins so the validator can't understand my code, that is why.
    ritajohansen.com is NOT mine, that is my friend's site...
    I have linked them (WordPress), just not on the frontpage...
    There are good reason why I have taken out all the stylesheets for wordpress, simply because ALL tags from the original file, like all the divs are GONE.

  7. serendipity
    Member
    Posted 9 years ago #

    Well, your letters are showing up ok now, so that's something achieved.
    I wasn't talking about your style sheets but the template itself (index.php or however you may have cut it into several files). It's always a good idea to check if the skins you're using don't leave out or put in something that's not ideal. And while I'm by no means crazy about validation, it's very helpful if your markup validates to get the site right the way you want it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.