WordPress.org

Ready to get started?Download WordPress

Forums

Says to install WP and then that tt's already installed (9 posts)

  1. Laurel83
    Member
    Posted 6 years ago #

    Sooo I did a really stupid thing and changed the siteurl. It was http://www.lolapie.com/blog. But I irrationally changed it to http://www.lolapie.com, knowing instantly that I made a huge error

    I was locked out of my blog, obviously, and went through the typical steps to fix it but they didn't work. I did these two:

    http://www.tamba2.org.uk/wordpress/site-url/
    http://www.village-idiot.org/archives/2007/07/04/wp-emergency-url/

    And I logged in through Http://www.lolapie.com/blog/wp-login.php

    Anyway, all that didn't work so I tried to restore my options-general.php and now it says:
    It doesn't look like you've installed WP yet. Try running install.php.

    But when I click "install.php" it says:
    Not Found 404 but it's because it reverts back to this: http://lolapie.com/wp-admin/install.php

    So, I add in the "/blog" before the "/wp-admin" and it tells me that WordPress is already installed.

    Has anyone seen anything like this before? I am completely locked out of my blog. I have been researching this for hours and I can't seem to find any answers. Thanks in advance!!

  2. Ben L.
    Member
    Posted 6 years ago #

    Go into your mysql database and go to the options table, change the siteurl option (it's probably the first option there) back to what it should be.

  3. Laurel83
    Member
    Posted 6 years ago #

    I already did that--it doesn't help.

  4. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Use ftp and go to your wp-header.php

    It should read

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('.blog/wp-blog-header.php');
    ?>

    If not change and save. Now it will be looking for wp-blog=header.php in yoursite.com/blog/

  5. Laurel83
    Member
    Posted 6 years ago #

    I can't seem to find my wp-header.php

    All I see is wp-blog-header.php

  6. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Sorry, getting ahead on myself. Go to index.php. Change as above. Now it will be looking for wp-blog/header.php in yoursite.com/blog/

  7. Laurel83
    Member
    Posted 6 years ago #

    Ok, I looked at my index.php and that's where the:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('.blog/wp-blog-header.php');
    ?>

    code is. But it still didn't help.

  8. Laurel83
    Member
    Posted 6 years ago #

    Should I change something in wp-blog-header.php?

  9. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Go back to your database. As Nightgunner5 said, this is where to fix it. See what your db says in "wp_options". Click on edit. Change it to read http://www.lolapie.com/blog. Make sure the save button is checked and click on go. You should confirm here that the change was saved correctly.

    Back out of the db. Wait a couple of minutes and try to get to your website.

Topic Closed

This topic has been closed to new replies.

About this Topic