WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
Saving causes a HUGE increase in size of DB (7 posts)

  1. jsghagan
    Member
    Posted 1 year ago #

    Hi there. I am attempting to use this plugin and here are the results:

    1. I restore a db from backup, which is about 18MB.
    2. I go into Admin Menu Editor, change one thing (for example, reorder one menu item
    3. Hit 'Save Changes'
    4. It spins for a really long time and eventually I can't get to wp-admin anymore - it just displays a blank screen
    5. I do an export of the db and it is greater than 800MB

    Any suggestions? Questions?

    http://wordpress.org/extend/plugins/admin-menu-editor/

  2. jsghagan
    Member
    Posted 1 year ago #

    I noticed that in the wp_sitemeta table the rows that are save for admin menu editor are _way_ longer than they should be.

  3. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    That sounds like a bug or some kind of weird plugin conflict. Normally the menu data is around 100KB (kilobytes, not megabytes!). I've never seen it exceed 300KB. Also, saving the menu on one site should only create or update one table row, not many. How many rows are there and how long are they (on average) in your case? Does the number of menu-editor-related rows match the number of sites?

    It looks like you're running a multisite. How did you install the plugin - did you activate it separately on each site, network-activate it, or install it in /mu-plugins/? This can affect how it stores the menu.

  4. jsghagan
    Member
    Posted 1 year ago #

    Seems to be only in the case where it is activated in a multisite instance. I deactivated it in the network admin and activated in one site and it worked fine.

    So, is the plugin supposed to work for multisite?

  5. jsghagan
    Member
    Posted 1 year ago #

    It's specifically the wp_sitemeta table the gets so large, fyi.

  6. jsghagan
    Member
    Posted 1 year ago #

    I think I may have found the problem...there were 13000 ws_menu_editor records in the site_meta table...I deactivated the plugin, deleted all the records and reactivated it and it seems ok now.

  7. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, it's supposed to support multisite. When you network-activate it or install it in /mu-plugins/, it should use the same configuration on all sites and create just one ws_menu_editor record.

    Well, let me know if it starts generating lots of superfluous records again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.