WordPress.org

Ready to get started?Download WordPress

Forums

saving a page takes about 55 seconds (10 posts)

  1. jaymer
    Member
    Posted 9 years ago #

    hi all
    i've got my own dedicated server with no load. its a fast new box running FC2.
    i've setup a decent wordpress site over the last 6 weeks, but recently, it just takes a long time to make any change to a page.

    i ran phpmyadmin and clicked "show processes" and this is what it said:
    Show Full Queries ID User Host Database Command Time Status SQL-query
    Kill 1622 mt localhost mt Sleep 53 --- ---
    Kill 1648 mt localhost None Query 0 --- SHOW PROCESSLIST

    i kept refreshing it and saw the time count all the way up. after 53 seconds it went away and my page refreshed - it had just been sitting there after i'd hit "save"

    any ideas?
    i'm on whatever version was around 6 weeks ago, and it was running fine until about a week ago.

  2. Joshua Sigar
    Member
    Posted 9 years ago #

    By default, your blog ping ping-o-matic every publishing. That could slow you down. To disable it, go to Options -> Writing and delete the content of "Update Services" and hit "Update Options"

  3. jaymer
    Member
    Posted 9 years ago #

    I disabled both pings (I had added Technorati also) and it didn't improve anything at all.
    most of the time when i save (either a post or a page) it will take 55 seconds, but some times it is instant. I made a new Page and it saved instantly.
    In fact, I have 6 pages... 5 of them are subordinate to the main page. I can Edit them and each one saves instantly. But if I go back to a post, a simple Edit (and i really don't change anything) and Save and it takes 55 secs.

    any other ideas?

  4. Joshua Sigar
    Member
    Posted 9 years ago #

    I suppose it only pings when a Post is published, and not a Page.

    But you say there's still delay after disabling pinging? Any suspicious plugins?

  5. jaymer
    Member
    Posted 9 years ago #

    I just edited each of my pages... no problem.
    Then I edited 8 of my 9 posts and each saved also with no problem.
    Then when saving my latest, it delays.
    Then I made a new post with a copy/paste of my 9th post and it took a long time for its initial save.
    Then I made a new post with only 1 word in it and it saved instantly.

    Is there some issue with links that need to be somehow verified, because I had some recipes in this post and I had about 4 links out to other recipe sites. Is something going on where its hitting those sites to make sure the link is valid?

    thx
    jaymer...

  6. jaymer
    Member
    Posted 9 years ago #

    bump

  7. jaymer
    Member
    Posted 9 years ago #

    I just had "http://yada.yada.com/........" in multiple spots in my post and I removed "http://" from it. Sure, its not a clickable link now, but at least I don't have to wait 55 seconds to continue writing. What a drag.

  8. pcmt
    Member
    Posted 8 years ago #

    As a matter of interest I had the same problem. Saving an edited post (not page) was taking exactly 55 seconds to confirm the edited post was actually saved. But I noticed, by having the site open in another window, that the actual post update took place whilst I was still waiting in the other window for the admin page to do its work.

    I've now removed the ping ping-o-matic.

  9. grocal
    Member
    Posted 8 years ago #

    SOLUTION!
    Deactivate all ping-o-matic related stuff, XHTML self-checking etc. and comment out with # or two slashes "//" following lines in post.php file in wp-admin directory. Lines are:

    199: register_shutdown_function('do_enclose', $content, $post_ID );
    200: register_shutdown_function('do_trackbacks', $post_ID);

    and

    436: register_shutdown_function('do_trackbacks', $post_ID);
    437: register_shutdown_function('do_enclose', $content, $post_ID );

    It seems that only posts with lots of links are prone to be long posted due to some kind of checking of links. Disable this checking with commenting out those lines and posting happens INSTANTLY!!!

  10. Elliott
    Member
    Posted 8 years ago #

    grocal:

    It's a good solution, but didn't work for me. Posting or saving a post takes several minutes. It's happening on all my blogs lately and I'm not quite sure why.

Topic Closed

This topic has been closed to new replies.

About this Topic