WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Save changes to Page and get 404 instead (7 posts)

  1. Kathy_P
    Member
    Posted 4 years ago #

    I am trying to edit a pre-existing Page (not post) on my blog. I made some changes, then clicked Update Page. Instead of telling me changes were saved, I get taken to the 404 page of my blog. When I create a new page, I can add and save drafts until I get to about 450 words, then I start getting the 404 again. I also notice that the bar that tells me the word count is frozen on Saving Draft . . . I suspect something is going wrong with the Autosave feature.

    I installed the WordPress System Health plugin and it tells me about 75% of the rows in my database are revisions. It has highlighted this in red, so I don't think this is normal. There are only 16 posts. 164 rows in the table are revision.

    I already tried doing a clean install of WordPress. (I am using 2.8.4.) It didn't change a thing. Can anyone suggest other things to check?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - resetting your customer permalinks to the default setting?

  3. Kathy_P
    Member
    Posted 4 years ago #

    Esmi, thank you for taking the time to help.
    Deactivating all the plugins did not help. Resetting the plugins folder did not fix the problem. Switching to the default theme made no difference. When I changed the permalinks to the default setting, my browser couldn't find the site when I clicked Save Draft.

    I also used phpMyAdmin to Repair and Optimize the database. No problems were indicated.

    I really don't know what else to do.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    What permalink structure are you using?

  5. Kathy_P
    Member
    Posted 4 years ago #

    day and name. It worked fine on my previous webhost. I am now on a vps with LiquidWeb and they were the ones who ported my site over.

  6. Kathy_P
    Member
    Posted 4 years ago #

    Thanks to BYurick, via Twitter, the problem is solved. Mod_Security, an Apache module, was interfering with WordPress. I had to contact my webhost, and tech support whitelisted some "rules".

    I never would have figured this out on my own.

  7. Kathy_P
    Member
    Posted 4 years ago #

    Here is another thread that involves mod_security.

Topic Closed

This topic has been closed to new replies.

About this Topic