WordPress.org

Ready to get started?Download WordPress

Forums

Font - official webfonts plugin. NO CODING! Just click & change font size, color and font face v
[resolved] save button doesn't work in wordpress... (12 posts)

  1. jessandben2307
    Member
    Posted 1 year ago #

    Hi, what's the deal with this plugin!?

    Trying desperately to save changes and it just seems the save button has no action whatsoever!

    Really gutted at this plugin as I thought it would solve a lot of problems!

    Please could someone help me out!

    ben

    http://wordpress.org/extend/plugins/font/

  2. dean2013
    Member
    Posted 1 year ago #

    Agreed, I have exactly the same problem. The plugin would be absolutely perfect but it doesn't allow to save changed. I'm using the Twenty Eleven template from word press and unable to change the main header font and save it properly.

    It seems to change the font so you can see the style appear on the page but when it comes to actually saving it, it reverts back to the standard font style.

    I have tried selecting an element from page which appears to highlight the text and allow me to change the font but never saves it. I have tried different browsers including Google Chrome, IE and Firefox (all up-to-date versions).

    I think it may have something to do with the style.css of this particular template!? Not really sure what im talking about here but this plugin doesnt work. Ive tried re-installing it and have spent hours trying to make a simple text change but it never saves.

    It seems looking at this forum many other people have exactly the same problem, I have the latest version of the plugin also.

    Any help would be appreciated.

    Dean

  3. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys,
    When clicking on the "Save" button it saves settings with AJAX and then refreshes the page. Can you tell me what answer is coming back in the console just before the page refresh? This might be tricky but could help me to diagnose the problem.
    Press F12 to go to the console and you can see the answer in "Console" tab in Firefox or in "Network" tab in Chrome.

    Pawel

  4. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    Update:
    there's a new 6.1 version which was released specially for saving problems, and if it won't help you it will show a meaningful error info which you can post here. It fixes other compatibility problems too so I encourage to update now. Let me know if it helps, so I can mark the topic as resolved.

    Pawel

  5. mumseword
    Member
    Posted 1 year ago #

    Hello! I've the exact same problem. I've downloaded v6.1 and was happily changing all my fonts and sizes etc. But every time I click save, it goes back to default. Nothing is saved!

    When I click save when I'm viewing on my homepage, there's no message before it refreshes. It just reloads the entire page BACK to the previous default font.

    Please help.

  6. fausteffects
    Member
    Posted 1 year ago #

    Same thing here. I've saved the presets like Headline and paragraph, but when I go to another page and assign that preset to the text and SAVE, nothing happens on the other pages. The Home page is set, but the idea is, or so I thought, that we save it once and apply it to the other pages.

    No error is coming up and I've installed 6.1.

  7. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys,
    what are your websites URLs? I'm now able to monitor what font is downloaded from each URL so I can see what's happening in your case. Also please update to 6.11 which gives some guidelines like pick an element before making any changes which wasn't that clear when "Page title" was already existing and misleading.

    fausteffects - your problem is different. Some themes use different tags stucture for each type of page. That's why there's a button to add a new element to the current preset. The button was broken in the latest version that's why I made a new update just now. Please update to 6.11 and use the other button "Optional additional element".

  8. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    One more thing added. Forcing MIME types for web fonts in .htaccess file which might also help so make sure you're using 6.12 version. If the problem still persists, please post details of the problem and your website's URL where the effect (or no effect) of the plugin is visible.

  9. vahnilah
    Member
    Posted 1 year ago #

    Hey! I have the same problem on two blogs with 6.13. On a test site which is a fresh WP 3.5.1 and my real blog as well. I did solve it by changing the ftp permissions to 755 which I discovered by the F12 command but I don't know if it's practical or something you could fix to prevent when installing it as it was a headache for me to figure it out.

    I did the F12 console like you wrote and here is my error code when I load up a new post, change the font, click save, then update.

    Resource interpreted as Stylesheet but transferred with MIME type text/html: "http://adored.davidshotme.com/wp-content/plugins/font/generateEditorCSS.php". wp-tinymce.php:2
    GET http://adored.davidshotme.com/wp-content/plugins/font/font_files/vinterstad.woff 403 (Forbidden) /wp-content/plugins/font/font_files/vinterstad.woff:1
    GET http://adored.davidshotme.com/wp-content/plugins/font/font_files/vinterstad.ttf 403 (Forbidden) /wp-content/plugins/font/font_files/vinterstad.ttf:1

  10. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    Hi vahnilah,
    finally someone with really good info! I've just uploaded a new version which creates font_files folder on the fly instead of unpacking it. Let me know if it's writable immediatelly after installing.

    best,
    Pawel

  11. agusbagus
    Member
    Posted 1 year ago #

    Hi,

    I have same problem.
    It only changed the font colour but not the font sytle.
    I run it from local host.
    Here is what i got from console.
    Please advise. Thanks.

    [cycle] terminating; too few slides: 1 jquery.cycle.all.min.js:16
    Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://localhost/agusbagus/wp-content/plugins/font/font_files/eurof55.woff
    Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://localhost/agusbagus/wp-content/plugins/font/font_files/eurof55.ttf
    Uncaught Error: Parameter 2 (request) is required. schemaUtils:39
    FB.getLoginStatus() called before calling FB.init(). all.js:52
    Uncaught TypeError: Cannot call method 'error' of undefined jquery.fontPlugin.js:296

  12. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    Running from localhost might be a problem so better run it from a live website.

    I also made a new update which should fix saving problem for some people.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic