WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] "Same as Billing " Not working (13 posts)

  1. mchilson
    Member
    Posted 3 months ago #

    Since I upgraded several of my client sites to 3.8.14 then 3.8.14.1 the check-box that allows a user to have the same shipping address as a billing address simply makes both address disappear when checked. This is a problem on several sites and I have had to lock the user to entering both billing and shipping (which is ridiculous since they are all using paypal anyway). Any ideas what is going on here?

    Here is an example site:
    site

    Thanks in advance,
    Mike

    https://wordpress.org/plugins/wp-e-commerce/

  2. mchilson
    Member
    Posted 3 months ago #

    btw.. here is a screen shot of the cart when the "Same as Billing" is activated and the checkbox is clicked.

    Screen capture

    I've tried disabling all other plugins and reverting to teh 2014 theme. still does it.

  3. Jeff Pye Brook
    Member
    Posted 3 months ago #

    Hi Mike,

    When you updated to version 3.8.14 what version did you update from?

    Jeff

  4. mchilson
    Member
    Posted 3 months ago #

    Hi Jeff,

    I believe it was 3.8.9 before the .14 release and it was working fine with it.

    Thanks,
    Mike

  5. Mihai
    Member
    Plugin Author

    Posted 3 months ago #

    @mchilson
    Can you mail me at mihai@instinct.co.nz wp-admin and FTP info ?
    We would like to take a look and see whats going on.

    Mihai

  6. mchilson
    Member
    Posted 3 months ago #

    sure thing.. thanks for your time.

    Mike

  7. ryanoccg12
    Member
    Posted 3 months ago #

    hi... I have a same problem on my site

    http://doremi.my/products-page/checkout/

    can i know that do you have any solution already??

    and i was gold-cart member... i'm not sure izit related??

    please let me know how to solve if u have a way please..

    thank..

    my email was : ryano@tribeup.my

  8. Mihai
    Member
    Plugin Author

    Posted 3 months ago #

    @ryanoccg12
    In your case i think its theme related. When you check that box it normally does an ajax request to update the customer meta.
    On your store nothing happends when you click the box besides hiding all the fields.

    Do a quick change to the 2010 theme from WordPress and try with that.

  9. mchilson
    Member
    Posted 3 months ago #

    Thanks to Miha this is working again. For anyone else that might be interested this site had been upgraded over the years with quite a few versions of WPEC so some of the files that had been moved to the theme directory were out of date. Removing them and reapplying the new css and page files then adding the changes back in solved the issue.

    Thanks for all your help Mihai!

    Cheers,
    Mike

  10. raecp
    Member
    Posted 3 months ago #

    I was just called to look at a check out problem I think is related to this thread. The billing state in drop down menu not "holding" in check out -click submit and get error to fill in "state". Have tested repeatedly
    WP 3.9.1; WP eCommerce 3.8.14.1
    I think the cart was working, owner just discovered problem.
    Thank you for help! Rae

  11. colourcascadefabrics
    Member
    Posted 3 months ago #

    Help! Mine is doing the same thing

    http://www.colourcascadefabrics.com.au

    I am using the Bandana Theme, how can I fix this?

  12. raecp
    Member
    Posted 3 months ago #

    Make sure the billingstate is a mandatory field in setup - I FINALLY noticed the field was unchecked - now it is working. HTH.

  13. mchilson
    Member
    Posted 3 months ago #

    As stated above this fixed it for me...

    "For anyone else that might be interested this site had been upgraded over the years with quite a few versions of WPEC so some of the files that had been moved to the theme directory were out of date. Removing them and reapplying the new css and page files on the presentation tab of the store settings then adding the changes back in solved the issue."

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.