WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-to-lead for Salesforce CRM
[resolved] Salesforce Integration Only Works When Option Checked (9 posts)

  1. meetgeraldine
    Member
    Posted 10 months ago #

    My salesforce form only sends lead information to salesforce when "send me a copy" is checked. It does not work when the website viewer does not check the box.

    Please advise on how to fix.

    http://wordpress.org/plugins/salesforce-wordpress-to-lead/

  2. Nick Ciske
    Member
    Plugin Author

    Posted 10 months ago #

    Ummmm... that's interesting.

    That should not be happening ... so I can't tell you how to fix it without some info:

    1. Which version of the plugin are you running?
    2. Can I see a form with this issue (e.g. a link to a live form)?
    3. Does changing to a bundled theme fix the issue? (e.g. twenty twelve)?
    4. Does deactivating all other plugins fix the issue? If so, please reactivate one by one until the issue reappears to find the conflicting plugin.
  3. meetgeraldine
    Member
    Posted 10 months ago #

    thanks for responding...

    the client asked if we can just set it to checkmark itself automatically.

    can i do that by editing these codes somewhere? we need to launch soon so i think this would be more time efficient than troubleshooting.

    $content = $this->checkbox('showccuser',__('Allow user to request a copy of their submission', 'salesforce') );

    //send me a copy
    if( $options['showccuser'] ){
    $label = $options['ccusermsg'];
    if( empty($label) ) $label = __('Send me a copy','salesforce');
    $content .= "\t\n\t".'<p><label class="w2llabel checkbox"><input type="checkbox" name="w2lcc" class="w2linput checkbox" value="1"/> '.esc_html($label)."</label><p>\n";
    }

  4. Nick Ciske
    Member
    Plugin Author

    Posted 10 months ago #

    //send me a copy
    if( $options['showccuser'] ){
    $label = $options['ccusermsg'];
    if( empty($label) ) $label = __('Send me a copy','salesforce');
    $content .= "\t\n\t".'<p><label class="w2llabel checkbox"><input type="checkbox" name="w2lcc" class="w2linput checkbox" value="1" checked="checked"/> '.esc_html($label)."</label><p>\n";
    }

    checked="checked" is the key bit to add.

    The user can still uncheck it so it's not a perfect solution.

  5. meetgeraldine
    Member
    Posted 10 months ago #

    No worries, I plan to just make it transparent so they can't see it. Do you think that would work?

  6. meetgeraldine
    Member
    Posted 10 months ago #

    No worries, I plan to just make it transparent so they can't see it. Do you think that would work?

  7. Nick Ciske
    Member
    Plugin Author

    Posted 10 months ago #

    Display: none may cause it not to be submitted (not sure, you'd need to test).

  8. meetgeraldine
    Member
    Posted 10 months ago #

    I tried it and it did not work..

    However, what DID WORK is removing clear: both;

    Yaay!

  9. Nick Ciske
    Member
    Plugin Author

    Posted 10 months ago #

    I don't see how that'd work, but I'm glad it did.

    Whenever you want to share some info about your install, I'd like to see if this is a real bug, plugin conflict, or something else.

Reply

You must log in to post.

About this Plugin

About this Topic