WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce PagSeguro
[resolved] Sales aren't automatically concluded (2 posts)

  1. ruda.almeida
    Member
    Posted 1 year ago #

    Automatic sale notification and removing sold items from stock (as added in v1.1) isn't working for me.

    I have configured properly the plugins according to the FAQ ( https://github.com/claudiosmweb/woocommerce-pagseguro#configuraes-no-pagseguro or http://wordpress.org/extend/plugins/woocommerce-pagseguro/installation/ ). I have followed every step of the FAQ, including:

    - activating "Página fixa de redirecionamento", setting my redirect URL as "<mysite>/finalizar-compra/pedido-recebido/" (which is a valid URL);
    - deactivating both "Página de redirecionamento dinâmico" and "Redirecionamento com o código da transação" (this last one wasn't explicitly in the FAQ, so I had to guess!);
    - deactivating "pagamentos via API";
    - activating "RETORNO AUTOMÁTICO DE DADOS" and setting the same exact url as in step one;
    - generating a toking and pasting it on the plugin's options page;
    - filling the correct pagseguro email on the plugin's options page;

    - On the product's settings, I have enabled "automatic stock management" and set a number of units in stock.

    If I perform a test sale, I'm sent to the PagSeguro page, complete the sale, get redirected to the thank you page, a new pending sale shows up in the woocommerce dashboard, but the status never changes from pending -- actually it does, but to cancelled, a few hours later.

    Meanwhile, a few minutes later (or less), I get email confirmations from the PagSeguro merchant solution: one to the buyer and one to the seller (in this case, both are me as it's just a test). Both contain the PagSeguro transaction code, but it is essentially useless as I can't find a place to "translate" it into a WooCommerce sale ID.

    I'm using WordPress pt-br 3.5.1, woocommerce 2.0.4, and WooCommerce PagSeguro 1.3.4 (downloaded from github 4b7d0a5518). I have disabled every other plugin and reverted to the Twenty Eleven theme.

    I have the logs enabled, here's the log:

    03-25-2013 @ 17:34:28 - Payment arguments for order #1541: Array
    (
        [receiverEmail] => [REDACTED!]
        [currency] => BRL
        [encoding] => UTF-8
        [senderName] => Rudá Almeida
        [senderEmail] => ruda_woo_comprador@binkmail.com
        [shippingAddressPostalCode] => 20230070
        [shippingAddressComplement] => ap 202
        [shippingAddressCity] => Rio de Janeiro
        [shippingAddressState] => RJ
        [shippingAddressCountry] => BRA
        [extraAmount] => 0.00
        [reference] => WC-1541
        [senderAreaCode] => 55
        [senderPhone] => 21854161
        [shippingAddressStreet] => Rua do Lavradio
        [shippingAddressNumber] => 0
        [itemId1] => 1
        [itemDescription1] => Bodum Brazil Coffee Press 8 Cup
        [itemQuantity1] => 1
        [itemAmount1] => 0.25
    )
  2. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Keep calm xD

    The problem is not in my plugin or PagSeguro.

    In version 2.0 of WooCommerce has added a new option to stock:
    http://imm.io/10GnW

    Disable this option to the PagSeguro works.

    I'll document it in the plugin installation guide.
    Thanks for reminding me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.