WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce SagePay Direct Payment Gateway
[resolved] Sagepay direct (onsite) not completing order in Woocommerce (3 posts)

  1. callender
    Member
    Posted 1 year ago #

    Hi there

    I am using sagepay direct in woocommerce for payments on the site.

    The money is being captured. Sagepay mode is set to live.

    However, the order status of the orders is not being marked as completed.

    Also related to this - the order emails are not being sent out to customer.

    --

    I do not need pci compliance?

    --

    Can you please advise what I should be checking to make sure this is working correctly?

    Thanks

    http://wordpress.org/extend/plugins/sagepay-direct-for-woocommerce-payment-gateway/

  2. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi

    Does everything work in test mode?

    I would expect once the payment was taken the order status would show 'processing' and when you have sent out the goods you would set the status to 'complete'.

    In the custom fields on the admin order page should show the status of your transactions with SagePay and also in the SagePAy Direct table.

    regards

    Steve

  3. callender
    Member
    Posted 1 year ago #

    Thanks for the reply.

    I will check the custom fields.

    I didn't realise this is manual. Ie switching order from processing to complete.

    I have also noticed there is no ssl in place.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic