WordPress.org

Ready to get started?Download WordPress

Forums

Sabre
Sabre stops ALL registrations (8 posts)

  1. skippix
    Member
    Posted 1 year ago #

    No matter how I configure it, I can't get through the registration process.

    If I have stealth mode turned on, I get the following errors while trying to log in from my desktop (not my development machine):
    Unknown session
    Invalid session status
    Invalid IP address
    Session timed out
    Fake User

    If I turn stealth off, I only get these two errors:
    Unknown session
    Invalid session status

    Any help would be greatly appreciated!

    http://wordpress.org/extend/plugins/sabre/

  2. cecilporter
    Member
    Posted 1 year ago #

    Certainly broken, possibly abandoned?

  3. skippix
    Member
    Posted 1 year ago #

    AFAIK, it is dead. at the moment, i'm testing out http://wordpress.org/plugins/anti-captcha/

  4. wcrook
    Member
    Posted 10 months ago #

    Same problem. Let us know if you fix this SABRE.

  5. wcrook
    Member
    Posted 10 months ago #

    I was able to successfully fix this issue by doing the following:

    1 - Comment out the Session functions in the sabre_class.php file:

    Lines 336-346

    // if (empty($result->id)) {
    // $error_msg_text = __('Unknown session.', 'sabre');
    // $errors->add('sabre_session', $error_head_text . $error_msg_text);
    // $sabre_errors['sabre_session'] = $error_msg_text;
    // }

    // if ($result->status != 'pending') {
    // $error_msg_text = __('Invalid session status.', 'sabre');
    // $errors->add('sabre_session_status', $error_head_text . $error_msg_text);
    // $sabre_errors['sabre_session_status'] = $error_msg_text;
    // }

    2 - Uncheck everything under stealth options, and set session time to 20000

    3 - Turn off confirmation by user or admin. This still requires that the user check a valid email to receive their password, which should eliminate most spammers.

  6. wcrook
    Member
    Posted 10 months ago #

    Interesting, after committing my changes, I was then able to re-enable the "Check DNS Blacklists" and the "Block if Javascript Unsupported" under the "Stealth" options and all appears to be working.

  7. rosamundwo
    Member
    Posted 7 months ago #

    Thanks wcrook for your solution! It's really annoying getting all these spam

  8. wcrook
    Member
    Posted 7 months ago #

    After further frustration (for some reason the plugin had not created the database tables necessary to function correctly), I tried a different plugin, which I'm very pleased with:

    http://wordpress.org/plugins/stop-spammer-registrations-plugin/

    Even while Sabre was limping along (but working), I was still getting several spam registrations a day. Now that I've updated to use this new plugin, I get maybe one per week, and it has many other security features that seem to be working very well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic