WordPress.org

Ready to get started?Download WordPress

Forums

Russian text in Sidebar Text box (10 posts)

  1. russellcunning
    Member
    Posted 4 years ago #

    Hi - I've just installed two copies of WP (English version) on different servers, one in English, and a mirror with Russian text (but English admin - my Russian isn't good enough!!). I'm trying to add some Russian text to the Sidebars, but the Text widget turns any Russian text into something like this: п░п╫пЁп╩п╦п╧я│п╨п╦п╧ я▐п╥я▀п╨

    The whole Russian site is working fine by commenting out two lines in wp-config.php and changing the language code to KOI8-R - but it hasn't worked on the Text widget.

    Any ideas greatly appreciated.

    Sites are http://kyivenglish.com and http://kyivenglish.com.ua

  2. AxelYa
    Member
    Posted 4 years ago #

    I have a website where I mix english and russian languages. My database collation is set to utf8_general and I have no problem with displaying both languages.

  3. russellcunning
    Member
    Posted 4 years ago #

    Hi AxelYa, thanks for that. I do not have problems with the Russian language in pages or posts, but in the sidebar widget, Text, it doesn't display properly, nor as the title of any other sidebar box.

  4. AxelYa
    Member
    Posted 4 years ago #

    I have just tested it on the default theme and it was no problem at all.
    Could it be theme related ?

    btw, I opened the site you gave and I didn't see it.

  5. russellcunning
    Member
    Posted 4 years ago #

    Hi AxelYa, it is just images at the moment. I want to insert Russian text as titles etc. I also want to put the words Русский язык under the Russian flag on the .com page

  6. russellcunning
    Member
    Posted 4 years ago #

    Hi AxelYa, I just changed back from KOI8-R to UTF-8, and it's now displaying correctly..... I don't know why it didn't the first time around!! But thanks for your input, much appreciated.

  7. russellcunning
    Member
    Posted 4 years ago #

    Wow, this is interesting. If I have KOI8-R I can display Russian text in the pages and posts - but not in the sidebar widget 'Text'. But if I use UTF-8, the sidebar widget 'Text' displays correctly, but I can't use Russian text in the pages and posts. I just get a series of black diamonds with white question marks in them. I guess a lot more fiddling is needed.

  8. AxelYa
    Member
    Posted 4 years ago #

    Generally I like UTF-8 it works well with many languages.

    Also I totally forgot. You might check which language charset you use to type text. If you insert text in one charset and displaying in another it might cause diamonds or question marks. BTW your contact form question marks all over it.

  9. russellcunning
    Member
    Posted 4 years ago #

    I think I'm getting closer.... Yes, when I put the text in with KOI8-R and then changed the setting to UTF-8, I got all those diamonds..... I've installed another copy on a spare domain, and found that if I change the encoding, I have to put the text in again.

    I'm going to go with UTF-8, because it allows the sidebar widgets to work in Russian font.... but one thing I gleaned from another site was to remark out two lines in the wp-config.php file. They are:

    define('DB_CHARSET', 'utf8');

    and

    define('DB_COLLATE', '');

    change to:

    //define('DB_CHARSET', 'utf8');

    and

    //define('DB_COLLATE', '');

  10. AxelYa
    Member
    Posted 4 years ago #

    Few years ago I worked with another platform and we had a lot of pain making multilingual websites. Different charsets for each language and forcing database to print in certain charset. And Unicode was a remedy for the pain. Since then I am prounicode.

    I would create database in UTF-8 general_ci and made sure that collate is also utf-8 general_ci ( if it is utf-8 latin it will output question marks )

    Leave wp-config with default settings.

    Type all text using admin panel or made sure that notepad is set to unicode ( It is not recommended to copypaste from word software )

    Basically, go with default wordpress. Just IMO.

Topic Closed

This topic has been closed to new replies.

About this Topic