WordPress.org

Ready to get started?Download WordPress

Forums

WP-TopBar
[resolved] Russian Language not working / Cant add Query to the phpmyAdmin (7 posts)

  1. Vmialik
    Member
    Posted 11 months ago #

    My TopBar does not support my local language

    So I tried to add this:

    The problem is with your table collation. You need to change the collation to utf8_general_ci.

    Run this query from your phpMyAdmin to change the collation.

    ALTER TABLE 'DATABASEPREFIX'_topbar_data CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci

    Of course, make a backup of your table first!

    Get this error:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''DATABASEPREFIX'_topbar_data CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_' at line 1

    Whats up? Maybe I need to run this in specific SQL table or what? I am in the right database.

    http://wordpress.org/plugins/wp-topbar/

  2. Bob
    Member
    Plugin Author

    Posted 11 months ago #

    Change the word "DATABASEPREFIX" with the database prefix in wp-config.php

    Bob

  3. Vmialik
    Member
    Posted 11 months ago #

    Great I thought that might be it, but I wanted to check thanks for a quick reply Bob.

    Another concern right now rgtsf.org shows english notification and rgtsf.org/ru shows the Russian. Can I make it so that any page on rgtsf.org/ru/... would show one notification ie russian for all the pages under that directory. Otherwise I have to do it manually for each page and this is not sustainable thanks

  4. Bob
    Member
    Plugin Author

    Posted 11 months ago #

    You can use the "Category ID" option on the Control tab to include/exclude based on Category.

    Create a new Category called "Russian".
    Assign the new "Russian" category to every page and post that is in Russian.

    For each TopBar, on the Control Tab:

    Set those that are in Russian to be "include"
    Set those that are not in Russian (English?) to "exclude"

    Bob

  5. Vmialik
    Member
    Posted 11 months ago #

    Ok i see so I can do that for posts, but for pages I would have to manually add them correct?

  6. Bob
    Member
    Plugin Author

    Posted 11 months ago #

  7. Vmialik
    Member
    Posted 11 months ago #

    Yea thats an option thanks

Reply

You must log in to post.

About this Plugin

About this Topic